roudncube doesn't work

Discussion in 'ISPConfig 3 Priority Support' started by 007007, Jul 13, 2013.

  1. 007007

    007007 New Member

    Hi,

    I get roundcube displaying by disabling #php_value include_path .

    the file looks like

    Code:
    # Those aliases do not work properly with several hosts on your apache server
    # Uncomment them to use it or adapt them to your configuration
    #    Alias /roundcube/program/js/tiny_mce/ /usr/share/tinymce/www/
    #    Alias /roundcube /var/lib/roundcube
    
    Alias /webmail /var/lib/roundcube/
    
    # Access to tinymce files
    <Directory "/usr/share/tinymce/www/">
          Options Indexes MultiViews FollowSymLinks
          AllowOverride None
          Order allow,deny
          allow from all
    </Directory>
    
    #insert these lines
    <IfModule mod_php5.c>
    AddType application/x-httpd-php .php
    php_flag magic_quotes_gpc Off
    php_flag track_vars On
    php_admin_flag allow_url_fopen Off
    #php_value include_path .
    php_admin_value upload_tmp_dir /path/to/my/roundcube/temp
    php_flag register_globals off
    </IfModule>
    
    <Directory /var/lib/roundcube/>
      Options +FollowSymLinks
      # This is needed to parse /var/lib/roundcube/.htaccess. See its
      # content before setting AllowOverride to None.
      AllowOverride All
      order allow,deny
      allow from all
    </Directory>
    
    # Protecting basic directories:
    <Directory /var/lib/roundcube/config>
            Options -FollowSymLinks
            AllowOverride None
    </Directory>
    
    <Directory /var/lib/roundcube/temp>
            Options -FollowSymLinks
            AllowOverride None
    	Order allow,deny
    	Deny from all
    </Directory>
    
    <Directory /var/lib/roundcube/logs>
            Options -FollowSymLinks
            AllowOverride None
    	Order allow,deny
    	Deny from all
    </Directory>
    
    
    
    <Directory /usr/share/roundcube>
      Options FollowSymLinks
      <IfModule mod_php5.c>
        AddType application/x-httpd-php .php
        php_flag magic_quotes_gpc Off
        php_flag track_vars On
        php_admin_flag allow_url_fopen Off
        php_value include_path .
        php_admin_value upload_tmp_dir /var/lib/roundcube/tmp
        php_admin_value open_basedir /usr/share/roundcube:/etc/roundcube:/var/lib/roundcube:/etc/hostname:/etc/mailname:/var/spool/roundcube
        php_flag register_globals off
      </IfModule>
      <IfModule mod_dir.c>
        DirectoryIndex index.php
      </IfModule>
      # access to configtest is limited by default to prevent information leak
      <Files configtest.php>
        order deny,allow
        deny from all
        allow from 127.0.0.1
      </Files>
    </Directory>
    
    
    roundcube is displayed : https://94.23.203.76/webmail/

    but login doesn't work, I created an email account, but can't be logged

    amine3@butarek.com
    amine3

    how I can fix this issue?
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please try to disable the open_basedir setting as well.
     
  3. 007007

    007007 New Member

    I did, but still the issue, my conf file

    Code:
    # Those aliases do not work properly with several hosts on your apache server
    # Uncomment them to use it or adapt them to your configuration
    #    Alias /roundcube/program/js/tiny_mce/ /usr/share/tinymce/www/
    #    Alias /roundcube /var/lib/roundcube
    
    Alias /webmail /var/lib/roundcube/
    
    # Access to tinymce files
    <Directory "/usr/share/tinymce/www/">
          Options Indexes MultiViews FollowSymLinks
          AllowOverride None
          Order allow,deny
          allow from all
    </Directory>
    
    #insert these lines
    <IfModule mod_php5.c>
    AddType application/x-httpd-php .php
    php_flag magic_quotes_gpc Off
    php_flag track_vars On
    php_admin_flag allow_url_fopen Off
    #php_value include_path .
    php_admin_value upload_tmp_dir /path/to/my/roundcube/temp
    #php_flag register_globals off
    </IfModule>
    
    <Directory /var/lib/roundcube/>
      Options +FollowSymLinks
      # This is needed to parse /var/lib/roundcube/.htaccess. See its
      # content before setting AllowOverride to None.
      AllowOverride All
      order allow,deny
      allow from all
    </Directory>
    
    # Protecting basic directories:
    <Directory /var/lib/roundcube/config>
            Options -FollowSymLinks
            AllowOverride None
    </Directory>
    
    <Directory /var/lib/roundcube/temp>
            Options -FollowSymLinks
            AllowOverride None
    	Order allow,deny
    	Deny from all
    </Directory>
    
    <Directory /var/lib/roundcube/logs>
            Options -FollowSymLinks
            AllowOverride None
    	Order allow,deny
    	Deny from all
    </Directory>
    
    
    
    <Directory /usr/share/roundcube>
      Options FollowSymLinks
      <IfModule mod_php5.c>
        AddType application/x-httpd-php .php
        php_flag magic_quotes_gpc Off
        php_flag track_vars On
        php_admin_flag allow_url_fopen Off
        php_value include_path .
        php_admin_value upload_tmp_dir /var/lib/roundcube/tmp
        #php_admin_value open_basedir /usr/share/roundcube:/etc/roundcube:/var/lib/roundcube:/etc/hostname:/etc/mailname:/var/spool/roundcube
        #php_flag register_globals off
      </IfModule>
      <IfModule mod_dir.c>
        DirectoryIndex index.php
      </IfModule>
      # access to configtest is limited by default to prevent information leak
      <Files configtest.php>
        order deny,allow
        deny from all
        allow from 127.0.0.1
      </Files>
    </Directory>
    
    
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please take a look into the mail log file to see which error you get there. The mail.log is in the folder /var/log/
     
  5. 007007

    007007 New Member

    in mail.log there is:

    Code:
    Jul 17 11:38:04 serverks dovecot: auth-worker(default): mysql: Connected to localhost (dbispconfig)
    Jul 17 11:38:04 serverks dovecot: imap-login: Login: user=<amine3@butarek.com>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, secured
    Jul 17 11:38:04 serverks dovecot: IMAP(amine3@butarek.com): Disconnected: Logged out bytes=39/449
     
  6. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    This looks like a successful login. Are there no errors?
     
  7. 007007

    007007 New Member

  8. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Maybe you can try to install the roundcube app for ispconfig, this will install a new roundcube in the apps vhost which is connected to ispconfig trough the remote api:

    https://github.com/w2c/ispconfig3_roundcube

    so we can test if the mailsystem itself works fine and you have a clean new roundcube install. It should not interfere with your current installed roundcube.
     
  9. 007007

    007007 New Member

  10. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

  11. 007007

    007007 New Member

  12. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    The login works fine for me when I try it with the details above. Please chenge the password so nobody misuses this account to send spam trough your server.
     

Share This Page