Roudcube passwort change not possible

Discussion in 'ISPConfig 3 Priority Support' started by muekno, Nov 19, 2020.

  1. muekno

    muekno Member HowtoForge Supporter

    I am unsing ispconfig for years, actual I have version 3.2.
    I use Roudcube for webmail, there was a plugin that the user can change his/her password. I am shure I installed the plugin some time (years) ago and tested it. Never needed it till now. Now one of my customers need it but I she goes to setting, where, as I remenber the password change was, the page is not available. The Server is debian stretch (9) latest patch level.
    What can I do, where can I look for to make that working
    Thanks

    Rainer

    roundcube is already the newest version (1.2.3+dfsg.1-4+deb9u7).

    checked following this tut https://www.howtoforge.com/tutorial/ispconfig-3-roundcube-plugins-on-debian-stretch/
    everything looks OK
    Error log shows [19-Nov-2020 11:38:42 Europe/Berlin] PHP Parse error: syntax error, unexpected '$config' (T_VARIABLE) in /var/lib/roundcube/plugins/ispconfig3_account/config/config.inc.php on line 2
    can not find errors in that file
    <?php
    l$config['identity_limit'] = false;
    $config['remote_soap_user'] = 'rcmail-remote';
    $config['remote_soap_pass'] = 'REDACTED;
    $config['soap_url'] = 'https://12.34.56.78:8080/remote/';
    $config['soap_validate_cert'] = true;
     
    Last edited by a moderator: Nov 19, 2020
  2. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

  3. muekno

    muekno Member HowtoForge Supporter

    I followed the tutoril mentioned in the edit of my post which is for debian 9
    If I click on settings browser show "Seiet funktioniert nicht"
     
  4. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    I removed your password and IP from the post.
    Yor current config is
    Code:
    <?php
    l$config['identity_limit'] = false;
    $config['remote_soap_user'] = 'rcmail-remote';
    $config['remote_soap_pass'] = 'REDACTED;
    $config['soap_url'] = 'https://12.34.56.78:8080/remote/';
    $config['soap_validate_cert'] = true;
    There are several issues here:
    1: there shouldn't be a l at the start of line 2
    2: If you use the IP address, it will most likely not have a valid cert. So validate_cert should be set to false.
    Try this config (make sure to set the correct password and IP address):
    Code:
    <?php
    $config['identity_limit'] = false;
    $config['remote_soap_user'] = 'rcmail-remote';
    $config['remote_soap_pass'] = 'REDACTED;
    $config['soap_url'] = 'https://12.34.56.78:8080/remote/';
    $config['soap_validate_cert'] = false;
     
  5. muekno

    muekno Member HowtoForge Supporter

    Thank you
    it works now. And sorry I did not see the "l" at start of line 2 :-(
    Rainer
     
  6. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    No problem ;) Glad to hear it works.
     

Share This Page