[email protected] ...

Discussion in 'Installation/Configuration' started by xma, Jul 14, 2006.

  1. xma

    xma New Member

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    What is in your /etc/postfix/alias file?
  3. xma

    xma New Member

    In main.cf i have:
    alias_maps = hash:/etc/aliases

    And I think I have a standard /etc/aliases, is a large file with names like:
    # General redirections for pseudo accounts in /etc/passwd.
    administrator: root
    daemon: root
    lp: root
    news: root
    uucp: root
    games: root
    man: root
    at: root
    postgres: root
    mdom: root
    amanda: root
    ftp: root
    wwwrun: root
    squid: root
    msql: root
    gnats: root
    nobody: root

    And one that points root to my local username.
  4. falko

    falko Super Moderator ISPConfig Developer

    Either remove that alias from /etc/aliases and run
    afterwards, or turn on the spamfilter for your email account in ISPConfig.
  5. xma

    xma New Member

    Hi Falko,

    In action you comment, I only disable forwarding root mails to my user, but root will continue recieving mails from [email protected], [email protected] ...

    I was thinking in a make a black list of local usernames destinations maybe in spamassassin or in postfix, is it possible?

    Some thanks
  6. falko

    falko Super Moderator ISPConfig Developer

    Then you must create an email alise called root for one of the email accounts of these domains.
  7. xma

    xma New Member


    I have been making different test and I look this:

    There are local usernames like:


    And a virtusertable like:

    [email protected] domain1.user11
    [email protected] domain2.user21
    [email protected] domain2.user22

    At this point all seems ok, but when I send a mail to [email protected] the mail arrives OK to domain2.user22.

    It seems like there aren't restrictions between usernames and domains, all localusernames can recieve mails at all domains.

    I revised postfix configuration, I disabled aliases sentence without solve the problem.

    Please, ┬┐anyone can make this kind of test and tell me the results?
    It a normal functionality of postfix/ispconfig?

    Some thanks in advance.

  8. falko

    falko Super Moderator ISPConfig Developer

    This is the normal behaviour.
  9. xma

    xma New Member

    In my opinion,

    It shouldn't be like that, because it generates a lot of spam between usernames in diferent domains, don't you think so?

    Did you know if I can't do anything to solve this fact? actually my username recieves more than 100 spam daily, and I only have less than 10 domains in a box. Imagine when I have 30 o more domains,

    Is anybody in the same problem?

    Some thanks to all
  10. Ben

    Ben ISPConfig Developer ISPConfig Developer

    One thing is the "light" configuration of postfix.
    You can e.g. check if the mail comes from dialuphosts and deny them (because if sb. sends mail from a server with a dynamic address its his own problem, but that you have to decide on your ow), as well as machines identifying with your server's address in HELO / EHLO.
    Mor than that you can also activate greylisting.

    All together it works really fine for me reducing spam.
  11. xma

    xma New Member

    But the big problem is that one user can recieve emails from other domains.

    How the big ISP using postfix solve this?

  12. falko

    falko Super Moderator ISPConfig Developer

  13. xma

    xma New Member

    I added spamhaus BL in smtp client restrictions in main.cf and seems I recieve less spam.

    Some thanks to all for the replies

Share This Page