root access problem in /var/www/clients/clientX/webXX/

Discussion in 'Installation/Configuration' started by asticot, Mar 28, 2013.

  1. asticot

    asticot New Member

    Hi,

    I recently migrate ISPCONFIG 3.0.4.x to 3.0.5

    I created 3 websites (web16 / web18 / web19)

    root@xxxxx:/var/www/clients/client1# ls -l
    drwxr-x--x 11 web1 client1 4096 28 nov. 13:06 web1
    drwxr-x--x 7 web14 client1 4096 22 janv. 18:10 web14
    drwxr-x--x 6 web15 client1 4096 28 mars 02:11 web15
    drwxr-xr-x 9 root root 4096 28 févr. 03:53 web16
    drwxr-xr-x 9 root root 4096 27 mars 10:59 web18
    drwxr-xr-x 9 root root 4096 28 mars 01:25 web19

    First, I noticed that now permissions for folders webXX has changed compare to ISPCONFIG 3.0.4.x; Is that normal ?



    Next, when I try to create a directory into one of the 3 new folders, I received an error (I am logued as root !)

    root@xxx:/var/www/clients/client1/web16# mkdir plop
    mkdir: impossible de créer le répertoire "plop": Permission non accordée

    I have no problems with olders fodlers like "web14", "web15" that were created using ISPCONFIG 3.0.4.x

    Any idea on what happened ?

    Thank you !
     
  2. till

    till Super Moderator

    The folder is protected with the immutable attribute.
     
  3. asticot

    asticot New Member

    Thank you Till for your answer !

    As you noticed, it is also possible to change this behaviour in
    System > Server Config > Web > Permissions > Make web folders immutable (extended attributes)

    And, in order to remove the immutable bit folders, just do a :
    chattr -i <folder>
     
  4. MicioMax

    MicioMax New Member

    I lost one day because of this damned immutable flag....
     
  5. spazio

    spazio Member

    I kind a have a similar problem but...
    I copied /var/www to /var/www-2 for backup and now I can't delete some /var/www-2 sub content.
    here it is:
    The server is centos / ispconfig 3
    First made sure this was not immutable problem.
    [root@Server web2]# lsattr
    -------------e- ./private
    -------------e- ./tmp
    -------------e- ./cgi-bin
    -------------e- ./web
    -------------e- ./ssl
    -------------e- ./webdav
    -------------e- ./log

    Tried selinux related but same denied problems
    [root@Server web2]# find . -print0 |xargs -0 -n 1 sudo setfattr -h -x security.selinux
    setfattr: .: Operation not permitted


    I can't delete any of those folder, I get a permission denied.
    So I search and found the e stands for "uses extends for mapping blocks on disk"
    But didn't find any ways to remove it.

    Anyways I can delete that folder and sub folder?
     
  6. till

    till Super Moderator

    Try to use chattr -i, chattr +i is the only protection that is applied to the web root folder.
     

Share This Page