rndc reload on ispconfig

Discussion in 'Installation/Configuration' started by Ripeed, Jan 2, 2012.

  1. Ripeed

    Ripeed Member

    Hi, I have trouble with rndc reload. It works good but i do somethnig and on Master server ns1.domain.tld and now it is bad.

    I have primary and secondary DNS servers.

    When I do: rndc reload on primary:
    rndc: connect failed: connection refusedr
    On secondary works fine.

    I am using ISPconfig 3 on debian 6.0.3.
    I have instalation from this Tutorial

    I found that error when I edit DNS records. When I dig it, only on secondary server was updated records. For updatitng primary I must apply changes in webmin.

    Thanks for help!
  2. Ripeed

    Ripeed Member

    Meaby i something wrong in rndc.key.

    In webmin on secondary server i found options set RNDC and that say "sems like rdns is allready set"

    on primary i can set it by webmin... I dont know if I can set with webmin?


    I am still looking on internet and meaby its probleme with permission. But where and what permission:(?

    Syslog saying:
    none:0: open: /etc/bind/rndc.key: permission denied
    I remember the last thing what I do was changing named.conf.options. But I bring it back to default. Now I dont know:(
    Last edited: Jan 2, 2012
  3. DangerDevil

    DangerDevil New Member

    seems a firewall problem.
    stop it and test it again.

    if it works,
    allow localhost connections.
  4. Ripeed

    Ripeed Member


    With webmin I turn on the RNDC and webmin created rndc.conf.


Share This Page