rm -rf command: Permission denied even as root user

Discussion in 'General' started by diopear, May 1, 2013.

  1. diopear

    diopear New Member

    Hello,

    On my server I have installed the version 3.0.5.2 of ISPConfig. I created a Shell-User for a particular site and everything worked normally. Therein, I noticed that some folders were created inside the folder of the site, such as bin, dev, lib, lib64 and others.

    After testing, I delete users (Shell-User), and the folders remained. As root, I try to delete these folders with the command "rm -rf bin" and returns the error "rm: can not remove` bin ': Permission denied".

    When creating a user, I selected the Chroot Shell Jailkit

    I've tried several ways (chmod, chown, chattr -i), but it still fails. I need help.

    Thanks!
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    You have to remove the immutable attribute with chattr -i from the parent folder ( the web root folder). Btw, thats described in severak threads here in the forum and in the manual.
     
  3. diopear

    diopear New Member

    You're right, till. I had not thought on parent folder. Thank you!
     

Share This Page