RKHunter in OpenVZ VE

Discussion in 'Installation/Configuration' started by theWeird, May 26, 2011.

  1. theWeird

    theWeird Member

    Hey there,
    I've got a problem with RKHunter in my OpenVZ VEs.
    Because the VEs cannot access the installed kernel modules RKHunter sends me a mail each day containig the following line:
    Code:
    Warning: The kernel modules directory '/lib/modules' is missing or empty.
    Can you tell me how to disable the kernel module check of rkhunter?
     
  2. falko

    falko Super Moderator ISPConfig Developer

    According to the man page (
    Code:
    man rkhunter
    ) this is not possible... :(
     
  3. theWeird

    theWeird Member

    I found the possibility to turn off some tests by adding 'os_specific' to the disabled tests in /etc/rkhunter.conf.
    But I think I'll try to write a mail rule instead to delete these notifications automatically.
     
  4. SamTzu

    SamTzu Member HowtoForge Supporter

    Why not simply add the missing folder to the VM?
    It works for me.
     
: openvz, rkhunter

Share This Page