Reverse DNS

Discussion in 'Installation/Configuration' started by PeekNPoke, Jul 31, 2010.

  1. PeekNPoke

    PeekNPoke New Member

    Hi all,

    Ok, before I get flamed. I've read about reverse DNS for the last week. I've also checked on this forum for answers, but with no luck.

    My problem is that I configure ISPConfig 3 with PTR records to point to my domain on the server, but it still doesn't get resolved locally on the box and remotely from some other box. Obviously this means I'm not configuring my DNS PTR record correctly.

    The hosting company I host my server with setup NS records that point to my server so I can resolve the in-addr.arpa address my self. The problem is ... how the hell do you do that. I've created PTR records on the domain I've setup on ISPConfig under the DNS tab. But it still doesn't resolve.

    I'm totally out of my depth now, and don't know how to go forward anymore.

    I've created the PTR record like so :

    Name : 194.72.45.204.in-addr.arpa.
    Canonical Hostname : ns2.unad.co.za.
    TTL : 86400
    Active : Checked

    No matter if I change them arround or not. I can't get 'n "dig @localhost -x 204.45.72.194" or a "host 204.45.72.194" or a "nslookup 204.45.72.194" to return any result.

    I obviously don't understand what I'm doing. Can anybody please give me a pointer or two ... please please please ....
     
    Last edited: Jul 31, 2010
  2. PeekNPoke

    PeekNPoke New Member

    Anybody get a suggestion ?
     
  3. falko

    falko Super Moderator ISPConfig Developer

    You must create a new zone, 72.45.204.in-addr.arpa, and in that zone you create a PTR record for 194 that points to ns2.unad.co.za.
     
  4. PeekNPoke

    PeekNPoke New Member

    Hi Falko,

    Thanks for the answer ... but I've just tried it and .. nope ...

    I've created a new DNS zone with :

    Zone (SOA) : 72.45.204.in-addr.arpa.
    NS : ns1.unad.co.za.

    Then added PTR records with:

    Name : 194
    Canonical Hostname : ns1.unad.co.za.

    With a "dig @localhost 204.45.72.194" ... no luck. Any other suggestions would be welcomed, thanks for your response.
     
  5. matty

    matty New Member

    Can you edit your zone file manually and check that the record you are looking at is like this:

    194.72.45.204.in-addr.arpa. IN PTR ns1.unad.co.za.


    You need to use dig -x for reverse lookups. :)
     
    Last edited: Aug 2, 2010
  6. PeekNPoke

    PeekNPoke New Member

    Hi Matty,

    Thanks for your reply as well. The problem is that ISPConfig 3 uses MyDNS, so no conf file is created. I've tried the "dig -x 204.45.72.194" on the server directly and it still didn't resolve. Check the output:

    :~# dig -x 204.45.72.194

    ; <<>> DiG 9.6-ESV-R1 <<>> -x 204.45.72.194
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 51364
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;194.72.45.204.in-addr.arpa. IN PTR

    ;; Query time: 76 msec
    ;; SERVER: 76.73.0.3#53(76.73.0.3)
    ;; WHEN: Mon Aug 2 14:07:04 2010
    ;; MSG SIZE rcvd: 44

    As you can see the Question is send but no answer is received. I'm really at my wits end ...

    Any other suggestion will be appreciated. Also please let me know if more info is required.
     
  7. falko

    falko Super Moderator ISPConfig Developer

    Are you absolutely sure that this is true? Please double-check.
     
  8. matty

    matty New Member

    Yeah, it looks like it. Doing a trace shows this

    Hopefully, PeekNPoke's nameserver is actually ns1.unad.co.za/67.159.14.2. Interestingly, they delegated the entire IP address, so the solution is to create the zone as 194.72.45.204.in-addr.arpa, and have a record for 204.45.72.194 (194.72.45.204.in-addr.arpa.). I just tested this on my server and it works fine.
     
: dns, ptr, reverse

Share This Page