Reverse DNS not correct

Discussion in 'Installation/Configuration' started by maplesyrup, Dec 13, 2006.

  1. maplesyrup

    maplesyrup New Member

    I want to thank you for your expertise in all issues in these forums. I have searched for similar issues, but couldn't find one that helped. Have tried all I know.

    I am running ubuntu dapper drake set up using the perfect setup. Only change was to add another IP address to the system. Installed ISPConfig and am up and running with minimal email. I have configured DNS so I am authoritative for my domain, When users email AOL addresses (of all things), mail is rejected, with this in mail.log:

    Dec 12 07:24:36 mr01 postfix/smtp[18147]: 1C58A1C5951: to=<[email protected]>,[], delay=4, status=bounced (host[] said: 554-: (RLY:CH) 554 TRANSACTION FAILED (in reply to end of DATA command))

    AOL reverse DNS tool says:
    Reverse No PTR but got: 172800 IN CNAME 194.192/

    I'm sure it's something easy, but can't figure out what I am missing.
    Thanx for the help.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The reverse DNS records of the IP address is handled by your server housing or DSL / Cable provider and not by ISPConfig on your server. If you are running your server behind a DSL or cable line you should relay your mails through a trusted external mailserver, otherwise many providers will block your emails.
  3. maplesyrup

    maplesyrup New Member

    Thanx for the quick reply.

    Maybe I'm missing something here. I am a startup ISP, so I have my own mailservers, and I believe I shouldn't have to relay through others. I have a T-1, not cable or DSL (If they were available, I wouldn't be doing this!!), with a /27. All other email, or at least all I've been able to track, goes through.

    Thanx again.
  4. falko

    falko Super Moderator ISPConfig Developer

    What's the output when you run
    dig -x
    where is your IP address?
  5. maplesyrup

    maplesyrup New Member

    Here's the output:

    ; <<>> DiG 9.3.2 <<>> -x
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 58508
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 2, ADDITIONAL: 2

    ; IN PTR

    ;; ANSWER SECTION: 86400 IN PTR 86400 IN PTR 86400 IN PTR 86400 IN PTR

    ;; AUTHORITY SECTION: 86400 IN NS 86400 IN NS

    ;; ADDITIONAL SECTION: 86400 IN A 86400 IN A

    ;; Query time: 40 msec
    ;; SERVER:
    ;; WHEN: Thu Dec 14 17:43:19 2006
    ;; MSG SIZE rcvd: 187

    This is run from my server. Is that what you wanted?

    Thanx again!!
  6. falko

    falko Super Moderator ISPConfig Developer

    This is what I get:

    mh1:~# dig -x
    ; <<>> DiG 9.2.1 <<>> -x
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 17444
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    ;    IN      PTR
    [B][COLOR="Red"] 86400 IN    CNAME   194.192/[/COLOR][/B]
    ;; Query time: 409 msec
    ;; SERVER:
    ;; WHEN: Fri Dec 15 13:43:05 2006
    ;; MSG SIZE  rcvd: 69
    This looks strange for sure. :confused:
    You should contact the support of the ISP who gave you the IP address.
  7. maplesyrup

    maplesyrup New Member

    After much hassle with my bandwidth supplier, I had to manually insert PTRs for 194.192/27. This works now. I have cleaned up other loose ends, thanx to help from dnsreports and Cricket Liu. The last issue I have is that it seems postfix is using my second ip instead of my first. Email headers show the second address, instead of my original. I configured the Perfect Ubuntu 6.06 and ISPConfig and manually added the second IP. It is actually the same machine, just a second IP. A portion of an email header from my domain to another domain follows:

    X-Barracuda-Start-Time: 1167509606
    Received: from ( [x.x.x.195])

    My primary IP is x.x.x.194. You can see above that the second IP is just for my second name server. All entries in ISPConfig are for x.x.x.194. The only one for x.x.x.195 is

    Anyway, I believe this is causing 'Relaying denied' errors, in particular when sending to AOL, because resides at x.x.x.194.

    Can I easily change this? Where do I do it?

    Thanx many times over for your help.
  8. maplesyrup

    maplesyrup New Member

    Here's a typical bounce message from AOL:

    Reporting-MTA: dns;
    X-Postfix-Queue-ID: CF3EF1C5979
    X-Postfix-Sender: rfc822; [email protected]
    Arrival-Date: Sat, 30 Dec 2006 16:21:01 -0500 (EST)

    Final-Recipient: rfc822; [email protected]
    Action: failed
    Status: 5.0.0
    Diagnostic-Code: X-Postfix; host[] said: 550
    5.7.1 <[email protected]>... Relaying denied (in reply to RCPT
    TO command)

    Thanx again!!
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Please add this directive to your file and restart postfix:

    smtp_bind_address =

Share This Page