restore website permissions on update not working

Discussion in 'General' started by helptec, Apr 30, 2013.

  1. helptec

    helptec New Member

    Hi,
    since i have updated from ispconfig 3.0.4.6 to 3.0.5.1 is not working the feature that automatically restores correct ownership and permissions of website files on each update of website configuration in admin panel.

    Looking for info with google and in this forum i've found that someone says to
    • check "Set folder permissions on update" option
    • uncheck "Make web folders immutable"
    • resync all

    i've tried but still not working
    what should i do?
    Thanks
    Luca
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    The function works fine in 3.0.5.2. Why do you think that your current permissions are wrong? Are you aware that the permission scheme from 3.0.4.6 to 3.0.5.0 has been changed, so the permissions have to be different now.

    I wont do that if you host customers on the server. This feature is required to keep your website secure, thats why it ios enabled by default.
     
  3. helptec

    helptec New Member

    normally when a website is created are applied this permissions and ownership

    Code:
    ls -l /var/www/test.tsa.com/web
    total 24
    drwxr-xr-x 2 web32 client3 4096 Apr 30 16:39 error
    -rwxr-xr-- 1 web32 client3 7358 Apr 30 16:39 favicon.ico
    -rwxr-xr-- 1 web32 client3 1861 Apr 30 16:39 index.html
    -rwxr-xr-- 1 web32 client3   14 Apr 30 16:39 robots.txt
    drwxr-xr-x 2 root  root    4096 Apr 30 16:39 stats
    
    and it's ok

    now, for example, i do this:

    Code:
    chown -R root:root index.html
    chmod  -R 777 index.html
    chmod  -R 777 robots.txt
    
    and i get this

    Code:
    drwx--x--- 4 web32 client3 4096 Apr 30 16:39 ./
    drwxr-xr-x 9 root  root    4096 Apr 30 16:39 ../
    drwxr-xr-x 2 web32 client3 4096 Apr 30 16:39 error/
    -rwxr-xr-- 1 web32 client3 7358 Apr 30 16:39 favicon.ico*
    -rwxr-xr-- 1 web32 client3   26 Apr 30 16:39 .htaccess*
    -rwxrwxrwx 1 root  root    1861 Apr 30 16:39 index.html*
    -rwxrwxrwx 1 web32 client3   14 Apr 30 16:39 robots.txt*
    drwxr-xr-x 2 root  root    4096 Apr 30 16:39 stats/
    
    In version 3.0.4.6, updating website configuration results in a restore of permissions and ownership to the original scheme.

    In version 3.0.5.1 don't.

    Ok the permission scheme has changed.
    But it means that files owned by web32 or owned by root now is the same thing?
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    No.Just some folders that were owned by web user in prior versions are now owned by the root user.

    ISPConfig 3.0.5 does not change the ownership of files owend by root to the web user, it corrects only folder permissions and will change e.g. the client group to the new group if you assign the site to a different client. The reason is that the old behaviour could have been misused to get access to sensitive files under some circumstances.
     
  5. helptec

    helptec New Member

    Ok, so i was considering a feature something that was a bug... :D

    But in case something goes wrong will be useful to have a "restore website permissions" function in admin panel that could be runned once.

    Should i post this in "Feature requests" section?
     
  6. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Yes, this would be a useful tools indeed. Please post a feature request in the bugtracker:

    http://bugtracker.ispconfig.org
     
  7. helptec

    helptec New Member

    Submitted with id FS#2926
    Thanks
    Bye
     

Share This Page