[RESOLVED] Problem from new install Perfect server

Discussion in 'ISPConfig 3 Priority Support' started by sweetromain, Nov 2, 2017.

  1. sweetromain

    sweetromain New Member HowtoForge Supporter

    Hi,
    After probleme with migrate to new PHP. I want to prepare new server with last new configuration (https://www.howtoforge.com/tutorial...-stretch-apache-bind-dovecot-ispconfig-3-1/2/), but at : "apt-get install mailman" I have this two times
    "Traceback (most recent call last):
    File "/var/lib/mailman/bin/list_lists", line 50, in <module>
    from Mailman import MailList
    File "/var/lib/mailman/Mailman/MailList.py", line 51, in <module>
    from Mailman.Archiver import Archiver
    File "/var/lib/mailman/Mailman/Archiver/__init__.py", line 17, in <module>
    from Archiver import *
    File "/var/lib/mailman/Mailman/Archiver/Archiver.py", line 37, in <module>
    from Mailman.i18n import _
    File "/var/lib/mailman/Mailman/i18n.py", line 37, in <module>
    _ctype_charset = _get_ctype_charset()
    File "/var/lib/mailman/Mailman/i18n.py", line 31, in _get_ctype_charset
    old = locale.setlocale(locale.LC_CTYPE, '')
    File "/usr/lib/python2.7/locale.py", line 581, in setlocale
    return _setlocale(category, locale)
    locale.Error: unsupported locale setting
    "
    And end with "
    dpkg: error processing package mailman (--configure):
    subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
    mailman
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    "
    I found this on web : https://askubuntu.com/questions/665830/error-updating-mailman
    But nothing, the problem presists.
    Cordialy


    EDIT : Repair with this :
    1. dpkg-reconfigure locales
    2. cd /var/lib/dpkg/info/
      rm mailman*
      apt-get clean all
      apt-get update
      apt-get upgrade
    3. apt-get install mailman
     
    Last edited: Nov 2, 2017

Share This Page