[RESOLVED] - ISPConfig 3 Supported TLD's

Discussion in 'Installation/Configuration' started by Phillip, Sep 29, 2017.

  1. Phillip

    Phillip New Member

    Are there any TLD's that ISPConfig3 cannot host w/ Apache?
    For example, we are using ISPConfig3, and trying to host a single domain on the .io TLD (wbi.io). It has the valid DNS records, etc, but apache is treating it like it doesn't exist. It is in sites-available/sites-enabled, and has the proper setup with servername and such, so not sure why it cannot find it.
     
  2. HSorgYves

    HSorgYves Active Member

    As far as I know ISPConfig can host all tld's with Apache. wbi.io gives me a Wordpress site...
     
  3. Tuumke

    Tuumke Member HowtoForge Supporter

    Same here, "just another wordpress site"
    Could been that the DNS replication hasnt gone through the whole interwebs ;)
     
  4. Phillip

    Phillip New Member

    Actually, it's not. You are seeing 'wordpress site' that is correct, but it's not WBI.io. WBI.io actually doesn't have anything but a basic YOURLS impelemtnation on it. The reason you are seeing a wordpress site is because apache is resolving it to the first available site (academydaytrading.com) which is a wordpress site.
    You can verify that by going to wbi.io/wp-admin

    I cannot even get it to work w/ ISPConfig.

    Code:
    [email protected]:/var/www$ ls -l
    total 24
    lrwxrwxrwx 1 root  root  30 Sep 28 18:02 academydaytrading.com -> /var/www/clients/client1/web7/
    drwxr-xr-x 2 ispapps ispapps 4096 Sep 26 16:59 apps
    drwxr-xr-x 3 root  root  4096 Sep 26 17:15 clients
    drwxr-xr-x 3 root  root  4096 Sep 26 23:14 conf
    drwxr-xr-x 2 root  root  4096 Sep 26 16:24 html
    lrwxrwxrwx 1 root  root  34 Sep 26 17:01 ispconfig -> /usr/local/ispconfig/interface/web
    drwxr-xr-x 9 root  root  4096 Sep 28 18:02 php-fcgi-scripts
    lrwxrwxrwx 1 root  root  30 Sep 27 15:40 ramora.wbi.io -> /var/www/clients/client1/web6/
    lrwxrwxrwx 1 root  root  30 Sep 27 00:21 tradingpsychologytest.com -> /var/www/clients/client1/web4/
    lrwxrwxrwx 1 root  root  30 Sep 26 21:58 turnkeytraderworkshop.com -> /var/www/clients/client1/web2/
    lrwxrwxrwx 1 web3  client1  30 Sep 26 21:59 wbi.io -> /var/www/clients/client1/web3/
    drwxr-xr-x 2 root  root  4096 Sep 29 06:25 webalizer
    As you can see, wbi.io is NOT a WP SITE.
    Code:
    [email protected]:/var/www/clients/client1/web3/web# ls -l
    total 204
    drwxr-xr-x 2 web3 client1  4096 Sep 27 02:22 admin
    -rw-r--r-- 1 web3 client1  4982 Sep 27 02:22 CHANGELOG.md
    -rw-r--r-- 1 web3 client1  861 Sep 27 02:22 composer.json
    -rw-r--r-- 1 web3 client1 20102 Sep 27 02:22 composer.lock
    -rw-r--r-- 1 web3 client1  2179 Sep 27 02:22 CONTRIBUTING.md
    drwxr-xr-x 2 web3 client1  4096 Sep 27 02:22 css
    drwxr-xr-x 2 web3 client1  4096 Sep 26 21:59 error
    -rwxr-xr-- 1 web3 client1  7358 Sep 26 21:59 favicon.ico
    drwxr-xr-x 2 web3 client1  4096 Sep 27 02:22 images
    drwxr-xr-x 5 web3 client1  4096 Sep 27 02:22 includes
    -rw-r--r-- 1 web3 client1  1063 Sep 27 02:22 ISSUE_TEMPLATE.md
    drwxr-xr-x 2 web3 client1  4096 Sep 27 02:22 js
    -rw-r--r-- 1 web3 client1  1807 Sep 27 02:22 LICENSE.md
    drwxr-xr-x 2 web3 client1  4096 Sep 27 02:22 pages
    -rw-r--r-- 1 web3 client1 38867 Sep 27 02:22 readme.html
    -rw-r--r-- 1 web3 client1 13802 Sep 27 02:22 README.md
    -rwxr-xr-- 1 web3 client1  14 Sep 26 21:59 robots.txt
    -rw-r--r-- 1 web3 client1  356 Sep 27 02:22 sample-public-api.txt
    -rw-r--r-- 1 web3 client1  5391 Sep 27 02:22 sample-public-front-page.txt
    -rw-r--r-- 1 web3 client1  1547 Sep 27 02:22 sample-remote-api-call.txt
    -rw-r--r-- 1 web3 client1  132 Sep 27 02:22 sample-robots.txt
    drwxr-xr-x 2 web3 client1  4096 Sep 29 00:04 stats
    -rw-r--r-- 1 web3 client1  3 Sep 28 18:07 test.html
    drwxr-xr-x 4 web3 client1  4096 Sep 27 02:33 user
    -rw-r--r-- 1 web3 client1  1534 Sep 27 02:22 yourls-api.php
    -rw-r--r-- 1 web3 client1  1265 Sep 27 02:22 yourls-go.php
    -rw-r--r-- 1 web3 client1 20354 Sep 27 02:22 yourls-infos.php
    -rw-r--r-- 1 web3 client1  2417 Sep 27 02:22 yourls-loader.php
     
    Last edited: Sep 29, 2017
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig is just writing an apache vhost file, not more and not less. What is served is up to apache and depends on factors like your dns records etc. A wrong site will e.g. show up when you used a wrong IP in NS or in the website or when you access the site by SSL but this site has no SSL cert. Take a look into the website vhost file to see if it contaisn the correct IP and if you use ssl, then check if it contains a second vhost for port 443.
     
  6. Phillip

    Phillip New Member

    VHOST Config (main parts)
    Code:
    [email protected]:/etc/apache2/sites-enabled# cat 100-wbi.io.vhost
    
    <Directory /var/www/wbi.io>
                    AllowOverride None
                                    Require all denied
                    </Directory>
    
    <VirtualHost *:80>
    
                                                                            DocumentRoot /var/www/wbi.io/web
    
                    ServerName wbi.io
                    ServerAlias www.wbi.io
                    ServerAdmin [email protected]
    So, it is configured for it. But, it appears it doesn't see it.
     
  7. Phillip

    Phillip New Member

    The VHOST config contains both :80 and :443 sections. And does have CERT. As is noted above, though, even though it exists in site-enabled and sites-available as configs, it's not finding it in apache2. Instead, it's returning the data from AcademyDayTrading instead (which is why I posted the directory structure of wbi.io as proof that it's not a WP site).

    To note, this is added to ISPConfig, as a shared site, so it's the same IP address as the server, like all the other sites we have on there. It's identifying to the proper IP w/o issue.

    So if ISP Config isn't the culprit, then apache2 is?
     
    Last edited: Sep 29, 2017
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Run the command:

    apache2ctl -S

    to see how apache 'sees' this vhost.
     
  9. Phillip

    Phillip New Member

    It seems to see the 2 primary IP's, and the named hosts shared on the *98.76 ip address. WBI.io is there

    Code:
    [email protected]:/etc/apache2/sites-enabled# apache2ctl -S
    AH00548: NameVirtualHost has no effect and will be removed in the next release /etc/apache2/sites-enabled/000-ispconfig.conf:72
    VirtualHost configuration:
    209.240.98.75:80       ramora.wbi.io (/etc/apache2/sites-enabled/100-ramora.wbi.io.vhost:7)
    209.240.98.76:80       academydaytrading.com (/etc/apache2/sites-enabled/100-academydaytrading.com.vhost:7)
    *:8081                 harkum.wbi.io (/etc/apache2/sites-enabled/000-apps.vhost:9)
    *:8080                 harkum.wbi.io (/etc/apache2/sites-enabled/000-ispconfig.vhost:9)
    *:80                   is a NameVirtualHost
             default server harkum.wbi.io (/etc/apache2/sites-enabled/000-default.conf:1)
             port 80 namevhost harkum.wbi.io (/etc/apache2/sites-enabled/000-default.conf:1)
             port 80 namevhost wbi.io (/etc/apache2/sites-enabled/090-wbi.io.vhost:7)
                     alias www.wbi.io
             port 80 namevhost tradingpsychologytest.com (/etc/apache2/sites-enabled/100-tradingpsychologytest.com.vhost:7)
                     alias www.tradingpsychologytest.com
             port 80 namevhost turnkeytraderworkshop.com (/etc/apache2/sites-enabled/100-turnkeytraderworkshop.com.vhost:7)
                     alias www.turnkeytraderworkshop.com
    *:443                  is a NameVirtualHost
             default server tradingpsychologytest.com (/etc/apache2/sites-enabled/100-tradingpsychologytest.com.vhost:149)
             port 443 namevhost tradingpsychologytest.com (/etc/apache2/sites-enabled/100-tradingpsychologytest.com.vhost:149)
                     alias www.tradingpsychologytest.com
             port 443 namevhost turnkeytraderworkshop.com (/etc/apache2/sites-enabled/100-turnkeytraderworkshop.com.vhost:130)
                     alias www.turnkeytraderworkshop.com
    ServerRoot: "/etc/apache2"
    Main DocumentRoot: "/var/www/html"
    Main ErrorLog: "/var/log/apache2/error.log"
    Mutex fcgid-pipe: using_defaults
    Mutex authdigest-opaque: using_defaults
    Mutex watchdog-callback: using_defaults
    Mutex rewrite-map: using_defaults
    Mutex ssl-stapling-refresh: using_defaults
    Mutex authdigest-client: using_defaults
    Mutex fcgid-proctbl: using_defaults
    Mutex ssl-stapling: using_defaults
    Mutex ssl-cache: using_defaults
    Mutex default: dir="/var/lock/apache2" mechanism=fcntl
    Mutex mpm-accept: using_defaults
    PidFile: "/var/run/apache2/apache2.pid"
    Define: DUMP_VHOSTS
    Define: DUMP_RUN_CFG
    Define: ENABLE_USR_LIB_CGI_BIN
    User: name="www-data" id=33
    Group: name="www-data" id=33
    
     
  10. Phillip

    Phillip New Member

    So, I noticed from the above output, that none of the IP's were set for the 3 other domain that use *98.76, so I did that. I updated ISPConfig to ensure the SHARED domains are on the proper IP.
    Now, the output looks like this:
    Code:
    [email protected]:/etc/apache2/sites-enabled# apache2ctl -S
    AH00548: NameVirtualHost has no effect and will be removed in the next release /etc/apache2/sites-enabled/000-ispconfig.conf:72
    VirtualHost configuration:
    209.240.98.75:80       ramora.wbi.io (/etc/apache2/sites-enabled/100-ramora.wbi.io.vhost:7)
    209.240.98.76:443      is a NameVirtualHost
             default server tradingpsychologytest.com (/etc/apache2/sites-enabled/100-tradingpsychologytest.com.vhost:149)
             port 443 namevhost tradingpsychologytest.com (/etc/apache2/sites-enabled/100-tradingpsychologytest.com.vhost:149)
                     alias www.tradingpsychologytest.com
             port 443 namevhost turnkeytraderworkshop.com (/etc/apache2/sites-enabled/100-turnkeytraderworkshop.com.vhost:130)
                     alias www.turnkeytraderworkshop.com
    209.240.98.76:80       is a NameVirtualHost
             default server academydaytrading.com (/etc/apache2/sites-enabled/100-academydaytrading.com.vhost:7)
             port 80 namevhost academydaytrading.com (/etc/apache2/sites-enabled/100-academydaytrading.com.vhost:7)
                     alias www.academydaytrading.com
             port 80 namevhost tradingpsychologytest.com (/etc/apache2/sites-enabled/100-tradingpsychologytest.com.vhost:7)
                     alias www.tradingpsychologytest.com
             port 80 namevhost turnkeytraderworkshop.com (/etc/apache2/sites-enabled/100-turnkeytraderworkshop.com.vhost:7)
                     alias www.turnkeytraderworkshop.com
             port 80 namevhost wbi.io (/etc/apache2/sites-enabled/100-wbi.io.vhost:7)
                     alias www.wbi.io
    *:8081                 harkum.wbi.io (/etc/apache2/sites-enabled/000-apps.vhost:9)
    *:80                   harkum.wbi.io (/etc/apache2/sites-enabled/000-default.conf:1)
    *:8080                 harkum.wbi.io (/etc/apache2/sites-enabled/000-ispconfig.vhost:9)
    ServerRoot: "/etc/apache2"
    Main DocumentRoot: "/var/www/html"
    Main ErrorLog: "/var/log/apache2/error.log"
    Mutex authdigest-opaque: using_defaults
    Mutex watchdog-callback: using_defaults
    Mutex rewrite-map: using_defaults
    Mutex ssl-stapling-refresh: using_defaults
    Mutex authdigest-client: using_defaults
    Mutex fcgid-proctbl: using_defaults
    Mutex ssl-stapling: using_defaults
    Mutex ssl-cache: using_defaults
    Mutex default: dir="/var/lock/apache2" mechanism=fcntl
    Mutex mpm-accept: using_defaults
    Mutex fcgid-pipe: using_defaults
    PidFile: "/var/run/apache2/apache2.pid"
    Define: DUMP_VHOSTS
    Define: DUMP_RUN_CFG
    Define: ENABLE_USR_LIB_CGI_BIN
    User: name="www-data" id=33
    Group: name="www-data" id=33
    
    So, it sees the shared name hosts under the *98.76 ip address for port 443 and port 80. And the other 2 domains do indeed work, but wbi.io now redirects to tradingpsychologytest.com, so apache2 still isn't serving it up.

    I'm still concerned that the '.io' TLD isn't supported.
     
  11. Phillip

    Phillip New Member

    ISSUE IS RESOLVED - I just gave up and deleted and re-added. While nothing changed in the config, it is now actually resolving. lol Don't know. Sometimes computers are odd haha
     
  12. HSorgYves

    HSorgYves Active Member

    Are you sure it's the same? Can you post the output of apachectl -S again?
     

Share This Page