Resolve problem with Etch

Discussion in 'Installation/Configuration' started by rvarkevisser, Apr 23, 2007.

  1. rvarkevisser

    rvarkevisser New Member

    I have a small problem with resolving and smtp.

    I run 3 ISPConfig servers with postfix mail. - debian sarge - debian etch - debian sarge

    I use NAT so I can't mail from mail1 to mail2 without using the host file and add mail2 and mail11 with the private ip space.

    mail1 -
    mail2 -
    mail11 -

    Now when I mail from mailserver 1 to mailserver 2 it works
    When I mail from mailserver 2 to mailserver 1 or 11 it doesn't work. When I look in my logging, I see that mail2 tries to connect to the public IP address of mail1 or mail11.
    mail1 and mail11 do this correctly and resolve mail2 to the private ip address.
    The network settings are identical, so I didn't setup DNS in the network interfaces, only in resolv.conf.
    The hosts file are (almost) identical and include all mailservers with their private Ip address.

    So what could be the problem? I have tried everything. Telnet to mail1 (using the dns name) or mail11 on port 25 works. Only when smtp tries to send a mail it shows the public ip in the mail.log. Also a reboot of all servers didn't solve anything.

    Who had a similar problem and knows a solution?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Does your linux setup has a file like /etc/host.conf? Some linux distributions use this file to store the resolf order, e.g. if the /etc/hosts file shall be used.
  3. rvarkevisser

    rvarkevisser New Member

    You've got to be kidding me! hahaha... oke. Found the file and added the line "order hosts, bind". I will have to restart my network, but can only do that tonight. I will try it.

Share This Page