reset client/customer number

Discussion in 'Installation/Configuration' started by nhybgtvfr, Feb 23, 2016.

  1. nhybgtvfr

    nhybgtvfr Member

    Hi,
    i've got an install where several clients have already been configured, and some deleted,
    so i now have clients showing as having id's c1, c3, c5.
    with clients with id's c2 and c4 having been deleted.
    however, now when i try to create a new client or reseller, it keeps pre-populating in the Customer No. field with the entry 'c3'
    which is already in use.
    i can change it manually, but is there any way to get it to start automatically filling it in from c6 and continue on in the sequence?

    also, if after some customer's have been deleted, if i manually add a customer in with one of the previously deleted id's, eg c2, will that mess up the numbering sequence again, or should it automatically continue on with eg c7?

    thanks.
    lee.
     
  2. nhybgtvfr

    nhybgtvfr Member

    as an addition to this,
    i've created a new reseller account, and then logged into ispconfig as the new reseller to add a client.
    the Customer No. field is pre-populated with c1, even though that is already used. that can't be right, and how is the reseller supposed to know what number they can put there? they can't just keep incrementing it by 1 until it works.
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    See System > Interfac config > Other.
     
    DDArt likes this.
  4. nhybgtvfr

    nhybgtvfr Member

    ah. thanks. can't believe i missed that, was looking at that just last week as well.

    saying that, i've changed customer no. counter to 5, and if i try (as admin) to add a new client, it pre-populates with c6, so that's ok.
    but if i log in as a reseller and try to add a new client, it's pre-populated as c1, and if i don't change that, i get:
    ERROR
    The customer no. must be unique (or empty).
     

Share This Page