required modules missing

Discussion in 'Installation/Configuration' started by etag1949, Jun 2, 2006.

  1. etag1949

    etag1949 New Member

    I can't get the installation to complete. I get as far as the middle of pg 6 at http://howtoforge.org/perfect_setup_ubuntu_5.10_p6 and get the "The PHP binary coming with ISPConfig does not work properly..." error apparently relating to:

    REQUIRED module missing: Digest::SHA1
    REQUIRED module missing: HTML::parser
    optional module missing: Net::DNS
    optional module missing: Mail::SPF::Query
    optional module missing: IP::Country
    optional module missing: Razor2
    optional module missing: Net::Ident
    optional module missing: IO::Socket::INET6
    optional module missing: IO::Socket::SSL
    optional module missing: LWP::UserAgent
    optional module missing: HTTP::Date
    optional module missing: Archive::Tar
    optional module missing: IO::Zlib

    warning: some functionality may not be available,
    please read the above report before continuing!

    ERROR: Could not configure SpamAssassin

    I don't know what I'm doing wrong here. The machine is a Dell PE4400, 2x1ghz Xeons, running Linux 2.6.12-9-686-smp #1 SMP kernel.

    I hope I've included enough to get some help!

    TIA, ernie
     

    Attached Files:

  2. till

    till Super Moderator

    It seems you missed the last installation step on page 5 of the howto:

     
  3. etag1949

    etag1949 New Member

    Duh!

    thnx, till...
    works like a charm

    ernie
     

Share This Page