renew ssl cert for postfix imap pop

Discussion in 'Installation/Configuration' started by chief, Jul 23, 2013.

  1. chief

    chief Member

    Hi,

    My cert has now expired for email.

    when using thunderbird connecting to imap on ispconfig 3, it asks me to confirm the certificate.
    I have examined the dates on my certificate and they have expired in march 2013, so they are well out of date.
    This answers some of the issues i have been having.
    my server uses another cert for the domain tlsystems.co.uk which expires in 2015, so i only need to renew the postfix cert.

    dave
     
  2. till

    till Super Moderator

    Code:
    cd /etc/postfix
    mv smtpd.cert smtpd.cert.bak
    mv smtpd.key smtpd.key.bak
    openssl req -new -outform PEM -out smtpd.cert -newkey rsa:4096 -nodes -keyout smtpd.key -keyform PEM -days 3650 -x509
    chmod o= smtpd.key
    /etc/init.d/postfix restart
    
     
  3. chief

    chief Member

    renew imap ssl cert

    Hi till,

    thanks for getting back to me. - i didnt state, fedora 15 with ispconfig 3.0.5.2 - sorry

    when i posted yesterday, i continued to stf, and found this link
    This updated my cert for IMAP and only took effect when i rebooted my server.
    Your reply adds a new cert for what program?

    also, when using an android or iphone mobile to connect to imap mail server, asks for incoming settings:- server=mail.server.com, username=me@server.com, password=******, security type=? i have choosen none here, port=143
    outgoing settings:- smtp=main.server.com, securitytype=none(i have tried ssl and tls, both state server does not support it), port=143(by default ssl uses 465 and tls uses 587 and neither works other than none) require sign in = not ticked.

    what do i need to edit/change to enable ssl and tls security?

    open tcp ports are = 20,21,22,25,53,80,110,143,443,993,995,3306,8080,8081,10000

    so do i need to open 587 and 465?
    so basically, how do i enable ssl or tls or both security types on my server

    cheers

    dave
     
  4. falko

    falko Super Moderator

    Port 143 is for IMAP, i.e., incoming emails. For outgoing mails, you should choose port 25, 465 or 587 (make sure they are open in your firewall). Also, ports 465 and 587 must be enabled in /etc/postfix/master.cf.
     

Share This Page