Remove domain from ISPConfig - what I have to do

Discussion in 'Installation/Configuration' started by pecka33, Apr 3, 2020.

  1. pecka33

    pecka33 Member


    i would like to remove some domays from my ISPConfig. What exactly i should to do? Just remvoe domain in panel and thats all? Because my domain use lets encrypt, i am not sure, but maybe i have to remove this LE from server manualy, somewhere in conf file for this domain. Or this is automatic after i delete it?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Delete domain from panel and then remove the LE cert manually, if you don't need the cert anymore.
    pecka33 likes this.
  3. pecka33

    pecka33 Member

    Thank you. I removed domain from panel. I found i have to delete following


    But problem is i cant see there ssl with this domain name. Probably because in command i used
    sudo certbot --apache -d -d -d

    So in this files i can see in archive, renewal etc files with name of first dmian and second file

    So probably both ssl has files for same domain name. Probably i have to remove files with name, but i am not sure 100%. I hope that is not problem if i dont remove this files and ssl will be still there, mean for example with auto renewal, if domain will not exist in isp panel/my vps.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    This command may never be used on ISPConfig servers as it destroys the config of the sites by duplicating it and makes them unmanageable. So if you had any issues with SSL or websites on this server in the past, then this was very likely caused by using that command. Due to the use of that command, ISPConfig is also not able to cleanly remove the site anymore, you have to remove it manually now.
  5. pecka33

    pecka33 Member

    Thank you. I used this command manytime, i dont know this. But all ssl working fine. When i remove domain i panel, will be removed from domain list in sftp.

    So what do you please recommend instead of this command? Not sure what exactly i have to remove, but via sftp i can not see any records with domain name i removed.
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    It gets removed in ISPConfig, but not from your server as the site has become unmanageable. It is very likely that apache will be down on next restart now and ISPConfig UI will become inaccessible.

    There is a checkbox named Let's encrypt in the website settings in ISPConfig. Enable that checkbox for the site, that's all you have to do.

    Search all apache config files with '-le' in their name in the sites-available and sites-enabled directory of apache and remove them. Then enable Let's encrypt for these websites in ISPConfig instead.
  7. pecka33

    pecka33 Member

    Thank you. I will try it. I know about ssl option in panel, but when i enable it, nothing happened, ssl still not working. This is reason why i did use this command. If i check it, after safe there is auto uncheck.
  8. till

    till Super Moderator Staff Member ISPConfig Developer

  9. pecka33

    pecka33 Member

    Thank you. I did reboot server as you wrote and you are right. Apache 2 was totally down. So i found via sftp files of cert for this domain, remove it, did restart apache and all wokring.

    I try to add my test domain to server and try it via panel.
  10. pecka33

    pecka33 Member

    That is amazing, removed all files you wrote, enable it via panel and working! Thank you!

    Main problem was probably because before i tried it in older version of panel.

    Newest domain working fine, but for my main domain i get error in error log
    2020-04-04 11:11:08,471:ERROR:certbot.log:There were too many requests of a given type :: Error creating new order :: too many certificates already issued for exact set of domains:, see

    Via command i wrote before i solved this that i add another domain there, but not sure how to solved it via panel.
  11. pecka33

    pecka33 Member

    Probably solved, add new subdomain in panel for this domain.

Share This Page