Remoting Framework... Teil3

Discussion in 'Developers' Forum' started by HeftiSchlumpf, Jan 3, 2009.

  1. HeftiSchlumpf

    HeftiSchlumpf New Member

    Nevermind.

    My question in short form

    Is there a Remoting Framework in Version 3.0.8 RC1 ?


    Will there be a stable version of Version 3 in 01.2009?

    Sorry, but i was too tired to figure out the german board.
     
    Last edited: Jan 3, 2009
  2. edge

    edge HowtoForge Supporter

    I'm also tired at the moment so I will answer you in Chinese.

    中央人民广播电台全国高校广播节目联盟锐意成为繁荣校园文化、推动先进文化和精神文明建设的新平台。扩大广播影响力,营造健康校园文化氛围是联盟的根本任务;帮助并培养善于表达有理想和能力的大学生为社会发展作出积极贡献是联盟的组织特性。联盟大批校园广播记者时时报道高校大事、要事、新鲜事,保证我们始终站在校园第一线。

    ·年中国大学生春晚回忆大学美好时光
    ·第四届“传媒影像力”原创影像大赛圆满落幕
    ·写在高校联盟两周岁

    Please keep it in English here!
    For German use the German forum!

    Thank you.
     
  3. till

    till Super Moderator

    there is no remoting framework for ispconfig 3.

    there is no remoting framework planned for 3.0.1 stabble, but maybe we add one later.

    And please do what edge suggested. If you wnat towrite in german, use the german forum and not the english forum.
     
  4. HeftiSchlumpf

    HeftiSchlumpf New Member

    Ok thats a bit bad btw. :)

    I am thinking right now of writing my own "Remote Service".
    If i will change something in the database, would it directly effect the behavior of ispconfig ?

    But if you can tell me, that the new remote framework in later version will be downward compatible to the current one, i could use it instead.
     
    Last edited: Jan 3, 2009
  5. till

    till Super Moderator

    No. Only changes that are also in the sys_datalog were written to disk.

    The remoting framework will not be downward compatible to ispconfig 2.
     
  6. HeftiSchlumpf

    HeftiSchlumpf New Member

    So in short word, there is not really a way to develop a remote client for ispconfig 3?

    Should i go down to 2.0 ? - The thing which matters for me is, that while developing the client or when i am finished with it, you will pop up with a new remote version and the whole work is gone. :/
     
    Last edited: Jan 3, 2009
  7. till

    till Super Moderator

    No, as ther is no remoting library avialable yet.

    The remoting library for ispconfig 3 will not be downwards compatible with the library for ispconfig 2 as ispconfig 2 and 3 are totally different and need different parameters for the functions.
     

Share This Page