remoting framework ip change problem

Discussion in 'General' started by blocker, Apr 29, 2009.

  1. blocker

    blocker Member


    i have the remoting framework installed and it worked perfect before i made some changes on the server.

    Before the change ispconfig and the apache webserver were running on one IP, i have added another IP to the server and now the ispconfig runs on the old one and on the new one i have configured apache from the distribution, furthermore ispconfig port is changed to the standard https - 443. Everything runs perfect except the remoting plugin. I have removed the remote user and recreted it - no change, i have removed the mysql tables regarding remote framework and reinstalled the framework - no change, the test.php is always returning:

    Script end ...
    ... i have also triple checked the settings in test.php - they seem to be fine, the reseller list stanza is active.

    Any ideas what might gone wrong?

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Most likely the problem is that you changed to https as this may cause problems if the remoting client is not able to handle ssl connections e.g. with curl.
  3. blocker

    blocker Member

    hello thanks for replay!

    it was previously on https://OLD_IP:81, now it is on https://NEW_IP, the ip and the port were changed, not the protocol. And the remote client is a site hosted on the same server...
  4. blocker

    blocker Member

    just tested the same configuration from a site hosted on another server and it works :eek:

    so it must be something with the local apache and php, but phpinfo(); is reporting that there IS a curl extension for php... what might be then wrong

    yes... stupid error, in /etc/hosts there was still the old IP pointing to the ispconfig host, which was overwriting the dns lookup, change it to the new and now everything seems to be normal
    Last edited: Apr 30, 2009

Share This Page