Remoting Framework Add User

Discussion in 'General' started by dayjahone, Oct 24, 2008.

  1. dayjahone

    dayjahone Member

    I don't get any errors when I run the test.php to add a user, but it also doesn't create the user. This is the function I am using:

    // Add User
    $params = array (         'sid'        => $session_id,
                                            'module'         => 'web',
                                            'function'         => 'user_add',
                                            'params'        => array ( web_title => '',  // web_title or web_id
                                            user_username =>joe,
                                            user_name => Joe,
                                            user_email => joe,
                                            user_passwort => joe,
                                            user_speicher => 0,
                                            user_mailquota => 1000,
                                            user_admin => 0
    $user_id = $soap_client->call('service',$params);
    if($err = $soap_client->getError()) die("Error: ".$err);/*
    Last edited: Oct 25, 2008
  2. st2xo

    st2xo New Member

    I had the same problem with ISPConfig 2.2.29 on OpenSuse11 and Remoting extension 4.2.1 Beta.
    Based on the "Test and Example Scripts" here do this:

    1. restart ISPConfig!
    /etc/init.d/ispconfig_server restart

    2. use this to add a user:
    (look related code in the test.php in the example scripts archive)
    // Add a User
    $params = array (
    'sid'=> $session_id,
    'module'     => 'web',
    'function'   => 'user_add',
    'params'     => array (
    web_title => 'domain.tld',  // web_title or web_id
    user_username => 'web1_stefan',
    user_name => 'My Name',
    user_email => 'emailname'// name before @
    user_passwort => 'mypassword',
    user_speicher => 1,
    user_mailquota => 2,
    user_shell    => 0,
    user_cron    => 0,
    user_admin => 0
    web_title did not work with the web_id like "web3" - it worked with the title, "domain.tld" (I insert the domain names for the title as default for all webs).
    Last edited: Jan 3, 2009
  3. st2xo

    st2xo New Member

    hmpf, confused now .... using the test.php in "Test and Example Scripts":

    'function' => 'kunde_get',
    'function' => 'kunde_list',​
    ..... works fine, results in browser, ispconfig.log has no entries

    'function' => 'kunde_add',​
    ..... works fine, results in browser, ispconfig.log has a lot of entries, also see mysqld.log (attached)

    'function' => 'user_add',​
    .... does nothing, no response in browser, ispconfig.log has no entry, also see mysqld.log (attached)

    is there anybody whose remote framework runs fine? On what system, what versions? Thanks for any help or hints ....

    Attached Files:

  4. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    works perfectly for me,

    dumb question, did you remember to remove the /* */ around the function in the test.php file? I havent done any work on the rf recently, but let me know if you resolved your issue, if it was a bug or if it was just user error

Share This Page