Remoting framework 2.2.17 Script end (no data) problem

Discussion in 'Installation/Configuration' started by wojtek, Oct 13, 2007.

  1. wojtek

    wojtek New Member

    I've installed the remote frameworking plugin for ispconfig ( no other actions regarding curl, ssl or php_soap module or anything - just webinstall of this plugin)

    I get no errors but get "Script end<br>" inc console which is obvious that in browser i get "Script end" too without any data . I have about 20 domains and 100 dns records.

    My version of ispconfig is 2.2.17.
    My script is listed below :

    $server_url = "";
    $soap_client = new soap_client($server_url.'/remote/index.php');
    $parameters = array('user' => 'blah',
    'pass' => 'secretblah');
    $session_id = $soap_client->call('login',$parameters);
    if($err = $soap_client->getError()) die("Error: ".$err);

    Then below i have the example function uncommented :

    $params = array ( 'sid' => $session_id,
    'module' => 'dns',
    'function' => 'zone_list',
    'params' => array ( reseller_title => 'all' // Reseller1, admin, all
    $dns_records = $soap_client->call('service',$params);
    if($err = $soap_client->getError()) die("Error: ".$err);

    WHere to look for the error ?

    Thanks in advance.

  2. wojtek

    wojtek New Member

    I hate to say things like that (I mean -I dont'know what was the cause of the error)

    1. I've reinstalled ispconfig 2.2.17 disabling the php "disable-xml" flag during compiling
    2. reinstalled (rm -fr 'ed ) the remoting framework plugin
    3. test.php WORKS.

    another problem is that it works only from local machine. dont have an idea why . more'over my local machine is in fact a remote machine because i use vserver and dont use localhost etc..

    more or less - it's working - thanks for anyone who read my post.

Share This Page