Remote Site Creation - DNS Problem??

Discussion in 'General' started by drum, Oct 1, 2006.

  1. drum

    drum New Member

    I've been using the remote framework to look at adding sites by PHP, however it looks like when a site is added using the framework no DNS records are created is this correct??

    $params = array (         'sid'        => $session_id,
                                            'module'         => 'web',
                                            'function'         => 'web_add',
                                            'params'        => array (         kunde_title => 'Test', // reseller_title or reseller_group
                                    web_title => '',
                                    web_host => 'www',
                                    web_domain => '',
                                    web_ip => '',
                                    web_speicher => '-1', // MB
                                    web_dns => 1,
                                    web_userlimit => -1,
                                    web_domainlimit => -1,
                                    web_shell => 1,
                                    web_cgi => 1,
                                    web_standard_cgi => 1,
                                    web_php => 1,
                                    web_php_safe_mode => 0,
                                    web_ssi => 1,
                                    web_ftp => 1,
                                    web_frontpage => 0,
                                    web_mysql => 1,
                                    web_mysql_anzahl_dbs => 30,
                                    web_ssl => 0,
                                    web_anonftp => 0,
                                    web_anonftplimit => 0,
                                    web_wap => 1,
                                    web_individual_error_pages => 1
    $web_id = $soapclient->call('service',$params);
    if($err = $soapclient->getError()) die("Error: ".$err);
    echo $web_id;
    Also note there is no DNS MX record, I noticed this is missing from the example code, is this deliberate??

    Other thing I noticed is the number of MySQL databases seems to be ignored, but I think this has already been reported.
    Last edited: Oct 1, 2006
  2. drum

    drum New Member

    Having played a bit more, it looks like the DNS record is created, however the folder is missing. If you search for the domain ISPConfig finds it, but any attempt to edit gives errors.
  3. drum

    drum New Member

    And after complete zapping all the DNS records manually in mySQL, it now works, so not sure if I managed to break it or not now. I suspect it might have been caused by the update from stable version, to dev version, so that I could use the Remote Framework.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats correct. The remoting framework provides separate functions to add DNS records.
  5. drum

    drum New Member

    Whay is there an entry for DNS in the example, is it redundant or does it have another meaning?

Share This Page