Remote Sending email problem

Discussion in 'Installation/Configuration' started by Alex1, Nov 12, 2007.

  1. Alex1

    Alex1 New Member

    I configure my mail client to use my server smtp, it works without problem when i send mail to the world, it gives an error when i send mails to address of domains hosted on the same server.
    Here is the log:
    Code:
    Nov 12 16:50:21 mizar postfix/smtpd[12121]: connect from 213-140-21-***.fastres.net[213.140.21.***]
    Nov 12 16:50:21 mizar postfix/smtpd[12121]: CE2D133C3B1: client=213-140-21-***.fastres.net[213.140.21.***], sasl_method=LOGIN, sasl_username=webX_user
    Nov 12 16:50:22 mizar postfix/cleanup[12124]: CE2D133C3B1: message-id=<20071112155021.CE2D133C3B1@mizar.domain.tld>
    Nov 12 16:50:22 mizar postfix/qmgr[19347]: CE2D133C3B1: from=<user@domain1.com>, size=2462, nrcpt=1 (queue active)
    Nov 12 16:50:22 mizar postfix/pickup[8324]: 2256E33C3E4: uid=10010 from=<webX_user>
    Nov 12 16:50:22 mizar postfix/cleanup[12124]: 2256E33C3E4: message-id=<20071112155022.2256E33C3E4@mizar.domain.tld>
    Nov 12 16:50:22 mizar postfix/qmgr[19347]: 2256E33C3E4: from=<webX_user@mizar.domain.tld>, size=394, nrcpt=1 (queue active)
    Nov 12 16:50:22 mizar postfix/local[12682]: 2256E33C3E4: to=<admispconfig@localhost.localdomain>, relay=local, delay=0.07, delays=0.04/0.01/0/0.02, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Nov 12 16:50:22 mizar postfix/qmgr[19347]: 2256E33C3E4: removed
    Nov 12 16:50:24 mizar postfix/smtpd[12121]: disconnect from 213-140-21-***.fastres.net[213.140.21.***]
    Nov 12 16:50:24 mizar postfix/local[12155]: 960F633C242: to=<webX_user@mizar.domain.tld>, orig_to=<info@domain1.com>, relay=local, delay=10, delays=1.4/0/0/9, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Nov 12 16:50:24 mizar postfix/qmgr[19347]: 960F633C242: removed
    Nov 12 16:50:29 mizar postfix/local[12146]: CE2D133C3B1: to=<webX_user@mizar.domain.tld>, orig_to=<user@domain1.com>, relay=local, delay=8.2, delays=0.33/0/0/7.9, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Nov 12 16:50:29 mizar postfix/qmgr[19347]: CE2D133C3B1: removed
    so the mail seems to be sended and also received but no mail is putted on incoming directory.
    Here is my postfix's main.cf:
    Code:
    # TLS parameters
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache
    
    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # See /usr/share/postfix/main.cf.dist for a commented, more complete version
    
    
    # Debian specific:  Specifying a file name will cause the first
    # line of that file to be used as the name.  The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname
    
    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    biff = no
    
    # appending .domain is the MUA's job.
    append_dot_mydomain = no
    
    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h
    # information on enabling SSL in the smtp client.
    
    myhostname = mizar.weitalia.net
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    #mydestination = mizar.domain.tld, localhost.domain.tld, localhost.localdomain, localhost
    relayhost =
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    inet_protocols = all
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination,check_policy_service inet:127.0.0.1:54000
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    mynetworks = 127.0.0.0/8 XXX.XXX.XXXX.0/27
    
    
    virtual_maps = hash:/etc/postfix/virtusertable
    
    mydestination = /etc/postfix/local-host-names
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    please activate the maildir checkbox in ispconfig under management > server > settings.
     
  3. Alex1

    Alex1 New Member

    already done, the mail works well, today the mail i try to send yesterday was arrived tagged as spam
     

Share This Page