Remote ISpConfig 3 Goes to Router

Discussion in 'Installation/Configuration' started by midcarolina, Jul 12, 2011.

  1. midcarolina

    midcarolina New Member

    I am not a newbie to Linux (not an expert either). I have established several VPS or VDS on other host accounts, usually w/ CentOS. I have since built my own server using Fedora 14 Linux. I installed (what seems to be a successful install), ISPConfig 3 and when attempting a remote login, am taken to the login for the Cisco Linksys router. Using XXX.XX.151.90:8080 (w/http://) to login expecting the initial username and password (per pdf user's manual) to be admin, admin, but instead am taken to the router. I have checked to make sure that the correct ports are open. What else could I be missing? Thanks in advance.
  2. Ghostdare

    Ghostdare Member

    Change the port of ISP Config, your router use the same port for management. Don't forget to create a rule in firewall for access outside your network.
  3. midcarolina

    midcarolina New Member

    Do you mean from :8080? That's sounds reasonable, only I don't know how to change the ports on ISPConfig. I do for the router. I bought the manual and have read it well. While it is good for setting-up and understanding ISPConfig, it doesn't give this type of information. Any suggestions or command line for doing so? Thanks again.
  4. Ghostdare

    Ghostdare Member

    Thanks to Till from another post (if you do a simple search)

    "The fix would have been to change the port in the file /etc/apache2/sites-available/ispconfig.vhost."
  5. midcarolina

    midcarolina New Member

    Thanks for the quick reply. The only problem is that I thought I was onto something similar, but yesterday when I checked, the command line stated that no such directory existed for /etc/apache2, to use /etc/hosts. I am using Fedora 14 x84_64 with the most updated packages and apache 2, so I am stumped. Sorry to bother, but thanks for your time, Bryan

    Yeah, just tried it with /etc/apache2 and /etc/hosts (just to see). Both not found.
  6. Ghostdare

    Ghostdare Member

    What tutorial do you use to build your server? I'm not a Fedora user but I think that apache is httpd, or just apache (without 2). Or if you can change the management port for the router...
    don't bother to change the port for ISPConfig.... just create a rule that 8080 point to the internal IP of your server. Or if you can update ISPConfig, when it ask on what port do you want to use for it.
    Last edited: Jul 13, 2011
  7. midcarolina

    midcarolina New Member

    Hi Ghostdare, it is ironic that you thought in advance of the solution. I did something similar and got everything working just great. Although I had already opened several ports in "port forwarding" in the router, such as 21 for ftp, 22 for ssh, 80, 8080, and several more strictly necessary to run the server etc., I perused the router a bit more, then Googled my findings. This is what resolved the issue (at least for a Cisco Linksys using Cisco Connect):

    There is Upnp which allows for http:// and https:// connection. After I enabled Upnp, rebooted the router, everything was perfect. I would have thought port forwarding would be enough, but apparently it needed Upnp enabled. Now, I don't know the forum rules in detail, but I ran into (what I consider a significantly smaller problem).

    The database was not complete for ISPConfig, so I figured an update would go. I couldn't log in because the sys_user was missing in the db , so I opened a new tar.gz file and "robbed" to dbispinconfig.sql file. Bingo!!! Now here is the catch, everything is operable so far, except that it won't allow me to create a servername inside of ispcong and I can't really create (in the right manner and fully) accounts and set quotas without this fundamental beginning. Any ideas? Thanks for all the help too.
  8. Ghostdare

    Ghostdare Member

    Try a forced update of ISP Config. Download the latest version of ISPC3.

    cd /tmp
    tar xvfz ISPConfig-3-stable.tar.gz
    cd ispconfig3_install/install
    php -q update.php
    Change ISPConfig-3-stable.tar.gz with actual name if has a different name.
  9. midcarolina

    midcarolina New Member

    Ok, gave that a try and here is the end result error I receive:

    This application will update ISPConfig 3 on your server.
    PHP Notice: Uninitialized string offset: 0 in /tmp/ispconfig3_install/install/lib/update.lib.php on line 98
    PHP Fatal error: Cannot use string offset as an array in /tmp/ispconfig3_install/install/lib/update.lib.php on line 98

    I know a tidbit about array, but not enough to adjust the file. Thanks Ghostdare
  10. Ghostdare

    Ghostdare Member

    I'm sorry.... this error beats me.
  11. midcarolina

    midcarolina New Member

    Well I have actually resolved this issue. In the error logs, there were two small but crucial packages that needed installation for vlogger and perl5 and mod_perl. The bad thing is that this particular section of the ISPC 3 manual gives a walk though with a Debian based system, so everything was wrong (Since I am using Fedora 14). So I basically took the info and looked for matches in the error logs. Fixed. Now I have one minor problem left, and hopefully you may be able to help?

    Inside of the ISPConfig Admin interface, it is crucial to "select" a server. I tried two methods, a namedvirtualhost with *80 and then going with an IP based host....still no option to select a server.

    Next, I went into the ispconfig mysql db table, found "server" and actually named it luck. Stuck. Thanks for your patience!
  12. Ghostdare

    Ghostdare Member

    To be more clear, you don't have a server to choose when you try to add a web domain?

    As i remember, Till or Falko, in one of their posts said that if you add manually in MySQL it will not replicate in web interface.

    So my recommendation is to try to use this tutorial with Fedora distribution, building you server from the beginning. Or try to build one around Debian (like Ubuntu). I work with ISPConfig almost from the beginning installed on Ubuntu, and it never made me hard days, even when i update packages or ISPConfig itself. Of course, my installation is on a virtual server on ESXi cluster.
  13. midcarolina

    midcarolina New Member

    Yes, when choosing a server, there is no option. My DNS is set properly, and my server name in /etc/hosts is and in /etc/sysconfig/networks it is also which should resolve:

    #hostname -s

    Am I correct in my thinking?
  14. CSsab

    CSsab New Member

    Hi midcarolina,

    Presumably you can now log into ISPConfig ...

    Have a look at the "system" ---> "server services" tab and is there a server listed there?

    If so, click on it and see what services are online.
    Last edited: Jul 15, 2011
  15. midcarolina

    midcarolina New Member

    Hi CSsab,

    Ok, in SSH as root, it is now showing [[email protected]~] Now if I use:

    #hostname -s I get what is correct #webserver

    I can login as admin in ISPConfig. "System", "Server Services" remains the same, blank (no options)???

    Thanks a lot for any clues
  16. Ghostdare

    Ghostdare Member

    If your server is not in production make a clean install. If you use Fedora I gave you a link with the tutorial for your distro. You have a broken ISP Config installation and I don't have any clues how to repair it.
  17. midcarolina

    midcarolina New Member

    Hi Ghostdare,

    I was sort of afraid it would result in this. As much as it pains me, I suppose it is the best move. I didn't see a link in your post, and really would like to use it if you still have it. Googling everything has gotten me exactly where I am now- with a "patch-work" quilt of a server that doesn't fully work! Thanks for all your time.
  18. Ghostdare

    Ghostdare Member

  19. midcarolina

    midcarolina New Member


    Thanks for all the help...much appreciated. Here goes nothing!

Share This Page