Remote Framework update beta 3.1- sql and lng files fixed

Discussion in 'Developers' Forum' started by grandpagenocide, Apr 7, 2008.

  1. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    Hey guys I fixed some bugs with the remote extentions, first I fixed the error that was stopping the sql db from being created in the users web, and second I added in the edited versions of the lng files in /lib/lang. I have tested it and its working fine. Falko, this is an addition since i sent you the updated version. I labeled it beta3.1.
    Now once ISPConfig is compile with xml extentions and libxml2-dev is installed, the remote framework will work without any editing of the lng files. I included all lng files that had the issue so it should work under all languages supported. , I put it up in there

    Attached Files:

    Last edited: Apr 7, 2008
  2. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    Falko & Till,
    If there is no objection, Ill take over the upkeep and updating of the remote framework, as I have to do it anyway for the billing system I am working on. I am going to add ruby and mailuser login etc to the remote, and whatever else i can find missing, if you can point out any todo's that you have for it let me know, and ill upload them to you as I update them.

    and just a dumb question, why is xml disabled in the stable releases anyway?
    Last edited: Apr 8, 2008
  3. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    ok guys heres 4.0 i didnt think i would be getting to these updates this soon.
    in addition to adding the lng files and the sql fix,
    I have added ruby and mailuser login to the remote framework.

    sorry was an error I just updated it 4/9/2008.

    Attached Files:

    Last edited: Apr 9, 2008
  4. ottojan

    ottojan New Member

    I downloaded the beta4 version, I noticed that there are some functions added for co-domains.

    domain_list and domain_add

    Can you help to add a domain_update function?

    I also noticed that the domain_list function only returns one co-domain per site (domain), is that a bug?

    And is it also possible to filter only c-domains for a singel site?
  5. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    I will be adding domain_update when I get some time off from work, and thanks for letting me know it only showed one co-domain on the list. Ill look into that, and yes it is possible, to list co domains for a single site, just havent thought of it :) you could try something like
    I am not sure if it would work, havent tried it, but let me know if it does
  6. jfunk

    jfunk New Member

    I just installed 4.1 beta and I noticed that SOAP Faults are not working properly. I enabled debugging in the client and I get the following messages if a fault occurs:

    soapclient: got response, length: 198
    soapclient: Entering parseResponse(), about to create soap_parser instance
    soapclient: soap_parser: Entering soap_parser()
    soap_parser: parse error: XML error on line 2: Invalid document end

    soapclient: sent message successfully and got a(n) NULL back
  7. jfunk

    jfunk New Member

  8. gauthier

    gauthier New Member

    Hi, thanks to grandpagenocide.

    I am using the ispconfig_remoting_ext_beta4_os version of remote framework, ISPConfig 2.2.23 on OS Centos5.

    It works fine to create webs, create users (email accounts) and update users. But it fails suspending or deleting webs.

    I have already cheked the remote user has permissions to delete and update websites. And I am trying first supending and then deleting.

    Debug shows the following:
    The line 376 is (I show it with the "------------->" string):

    Does anybody know why is this ?

    Also, I would like to know how shall I empty the recycle bins using framework.... (I thing there is no way...)

    Thanks a lot.
    Last edited: May 22, 2008
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Clients are not allowed to delete domains, this makes sense as they would not be able to create it again.

    Please try this:
    if(!isset($go_api->groups)) {
      $tmp_groups = $go_api->groups->myGroups();
      if(!is_array($tmp_groups)) {
        $sql = "UPDATE isp_nodes SET status = 1 WHERE doc_id = '$doc_id' AND doctype_id = '$doctype_id'";
    This should solve the problem as we do not have to query groups when we use the remoting framework and the group code is not loaded at all in this case.
  10. gauthier

    gauthier New Member

    I suppose you mean:

  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, thats what I meant :)
  12. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    update to remote framework 4.2
    new inclusions:

    fixed issue with webuseradmin coming up as kunde
    newest update is attached in a zip file

    Attached Files:

  13. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    should have added this in last post update to remote examples with the new features ;) and the autosignup script as well is included

    Attached Files:

  14. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    Bug Fix -- Remote Framework beta 4.2

    Well the webadmin login bug came back (rather i packed the wrong set of files) so here is the fixed version.

    Attached Files:

    Last edited: Aug 19, 2008
  15. gauthier

    gauthier New Member

    back with this...


    Thanks to grandpagenocide for his good work.

    I use: debian 4, ispconfig2.2.25, Remote Framework beta 4.2

    I made the change in /home/admispconfig/ispconfig/lib/classes/ispconfig_isp_domain.lib.php line 376:

    Remote framework can create and suspend web but not delete it (I used to delete web using remote framework on another server, so I know this is possible).

    Now the error I have is :

    I have already checked the remote user has permision to delete websites and DNS.

    I would be thankfull if someone can help me with this.

  16. bernholdt

    bernholdt Member

    im getting
    Installation instructions not found: /home/admispconfig/ispconfig/temp/a50e1e4f787ccff99668e4ea89828fe7/package.ins when trying to update
  17. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    bernholdt did you remove the db entries for remote in phpmyadmin? Sorry i havent written in the sql part, its on my todo list
  18. bernholdt

    bernholdt Member

    no i didnt dare to remove the entries manually :( wich entries are sopposed to be deleted
  19. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    drop tables remote_session and remote_user and you should be ok.
  20. bernholdt

    bernholdt Member

    still same error
    Installation instructions not found: /home/admispconfig/ispconfig/temp/4e1e875dd62df99bdd2127918ce434bc/package.ins

Share This Page