remote api

Discussion in 'ISPConfig 3 Priority Support' started by saco721, Jul 16, 2014.

  1. saco721

    saco721 Member HowtoForge Supporter

    Hi,

    I have multiserver setup with ISPConfig 3 on Debian Squeeze.

    I am trying to get the remote api working but am having problems, I go to the script and just get a blank page. I am aware the I my have missed some inputs in the script, but need some help to get it working. I have added a remote user freddyb with all privileges.

    Here is the script I am using :

    Thank you very much for your time.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Check the order of your code, you call a remote api function before you connect to the api.
     
  3. saco721

    saco721 Member HowtoForge Supporter

    Hey Till,

    thanks for your response.

    I have modified the script according to the tutorial

    I have tried to get the correct order for the code but am having problems. Here is the corrected code :

    I was wondering if the $username and $password, should be the remote user that I just added or shell user that I add via the control panel.

    Is $myusername, $mypassword, the username and password for the ftp user that i'm trying to add?

    Thank you for your patience!.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats the remote user. But the order is still wrong. Check out the exaple scripts that you find in the remote_client folder of the ispconfig tar.gz.

    you can not use:

    ... $client->sites_ftp_user_add( .....

    before you logged in with:

    if($session_id = $client->login($username,$password)) {
     
  5. saco721

    saco721 Member HowtoForge Supporter

    Hey Till,

    Everything working fine now,

    Thanks very much for your help!,

    Best wishes,

    Saco.
     

Share This Page