Remote access to DB does not work

Discussion in 'Installation/Configuration' started by mbogh, Aug 30, 2009.

  1. mbogh

    mbogh New Member


    When i activate remote access for a DB nothing happens, I am still not able to access the db remotely.

    The only firewall record is:
    20,21,22,25,53,80,110,143,443,3306,8080,10000 53,3306

    Am I missing something?

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You have to wait at least one minute, all changes are appliaed by a cronjob which runs once a minute.
  3. Franz

    Franz Member

    did you enable in mysql to listen on all interfaces?
  4. jon

    jon Member HowtoForge Supporter

    There is a bind-address line in your my.cnf (located in /etc/mysql/my.cnf on Debian). Usually it's set to by default. I believe you can just comment that line out.
  5. Craig

    Craig New Member

    Consider yourself lucky that you won't have bots trying to dictionary or rainbow attack your database. Allowing remote access to a data base through an unsecured channel is not a good idea.

    Instead, try something like

    That was written for connecting via MysqlAdministrator but the same concept can apply to just about anything you want to do, including talking from server to server.

    If at all possible, ALWAYS go through an ssl tunnel so that all access is not only secured but local.

    I should also add that remote access can be disabled depending on how one's grant table is populated. If a given user, or all users are only listed as using a local connection, including root, then no one can access remotely no matter what any other configuration you might have.
    Last edited: Sep 2, 2009

Share This Page