Remote access --Error: no transport found

Discussion in 'Developers' Forum' started by mxc, Aug 9, 2006.

  1. mxc

    mxc ISPConfig Developer

    Hi all,

    I am testing out the remoting framework. I get the error

    Error: no transport found, or selected transport is not yet supported!

    When I do

    $server_url = "https://".$this->server_ip.":81";
    $this->soap_client = new soap_client($server_url.'/remote/index.php');
    $parameters = array('user' => $userid,
    'pass' => $passwd);
    $this->session_id =$this->soap_client->call('login',$parameters);


    I have recompiled ispconfig with php including --with-curl and removed all the disable xml options. What am I missing?


    thanks
     
  2. falko

    falko Super Moderator

    Did you define $userid and $passwd?
     
  3. mxc

    mxc ISPConfig Developer

    yes --- they are passed in as parameters to the class constructor.
     
  4. falko

    falko Super Moderator

    Which PHP version do you use? PHP 5.1 comes with its own SOAP extension that is not compatible with the one from the remoting framework, so you'd have to disable PHP's SOAP extension in your php.ini.
     
  5. mxc

    mxc ISPConfig Developer

    I am using 5.1.4. I did get an error about the class soapclient being redefined but I assumed it was a typo and change the class name to soap_client. Will the remoting framework work with 5.1.4?
     
  6. till

    till Super Moderator

    I've not tested it with 5.1.4, but I geuess it will work.

    You can either use the soap libarary that we provide, then you will have to remove the soap extension in your php.ini and undo the renaming of the class. Or you use the soap extension that comes wth the latest PHP versions and do not use the soap library that we provide together with the remoting examples.
     
  7. mxc

    mxc ISPConfig Developer

    I have run debian in vmware player with php4 and i still get the same error. :(

    Could it be the security certificate not being valid?
     
  8. mxc

    mxc ISPConfig Developer

    found the problem. I had forgot to change the name of the soapclient constructor to soap_client when I renamed the class.
     

Share This Page