Release quaratined mail using mailwatch gui

Discussion in 'Server Operation' started by Goose, May 13, 2008.

  1. Goose

    Goose New Member

    From what I can find on the web there should be an option to release quarantined mail in MailScanner using the MailWatch gui but I can't find it.
     
  2. Rocky

    Rocky New Member

    Did you follow The Perfect SpamSnake guide? If so, then you should have the function on the MailWatch gui.

    Do the following:
    1. Open the MailWatch gui.
    2. Under the Recent Messages or in the Quarantine Messages Tab, you should see [ ] before each message.
    3. Click on that and it take you into the message.
    4. At the very bottom of the page, you'll see the checkbox for the Release function.
     
    Last edited: May 13, 2008
  3. topdog

    topdog Active Member HowtoForge Supporter

    yes you should be able to, the option is not shown if mailwatch can not read the quarantine directories try setting this option in conf.php

    Code:
    define(QUARANTINE_USE_FLAG, true);
     
  4. Goose

    Goose New Member

    There is no check box but I've had a look in detail.php and I can see the option. I guess it's being left out due to an if statement. I'll work through the script and see what I can find.

    Thanks

    <edit>

    define(QUARANTINE_USE_FLAG, true); is set and I have user: root, group: www-data, rwxrwx--- on /var/spool/MailScanner/quarantine and all sub directories. It does actually list the quarantined files and I can view each one. I just don't have the option to release them but will work through the detail.php script
     
    Last edited: May 13, 2008
  5. Rocky

    Rocky New Member

    Try the following:
    Code:
    chown -R postfix:www-data /var/spool/MailScanner
    
    If the above works, then you're good to go. If not, make sure the following settings are correct in /etc/MailScanner/MailScanner.conf:
    Code:
    Quarantine User = root 
    Quarantine Group = www-data 
    Quarantine Permissions = 0660 
    Quarantine Whole Message = yes 
    Always Looked Up Last = &MailWatchLogging
    
     
  6. Goose

    Goose New Member

    Tried that and no difference. I can see where it's failing in the details.php and am just tracking it through.
     
  7. Goose

    Goose New Member

    Sorted. Was a permission problem after all. I was sure I had doubled checked them.

    Thanks guys.

    Goose
    (looking for a job as a plumber instead)
     
  8. dimago

    dimago New Member

    I need help

    hello all,

    I was with the same problem. The release button doesn't appear.

    After fix the permissions, it appear to me.

    So, when I select the "e-mail message" in the end of the page and I click to release, don´t show the following message:

    "Message release to [email protected]"

    and off-course, the message doesn't delivered.

    This message appear in the mailwatch of my company, so I know that is the correct and should work.

    anyone knows how can I fix this?

    Thanks

    Diego
     
  9. Rocky

    Rocky New Member

    Does the message show in the message queue after being released? Make sure 127.0.0.1 is set as a whitelist item so that anything that is released does not get processed again.
     
  10. dimago

    dimago New Member

    one more doubt

    rocky, thanks for your help. I will check this..

    But, one weird thing is that don´t appear the link to open the message in the end of the page.

    I want to say that is possible to enter in the message to read the message, see the attachs and the body of the message, and release the message by this way.. in this case, the release are in top of the page, right?

    but to do all of this, I must to have a link to enter in the message. this link is near of release button in the first windows... in the end of page, right?

    So, I haven´t the link to click and open the message to read the body.. It´s so weird.. because of this, I guess that I have one more problem..

    I can post a image with this when I go home...

    diego
     
    Last edited: Aug 13, 2011
  11. dimago

    dimago New Member

    Perfect

    Hello,

    Thanks for the help.

    I fixed the permissions and now works perfect :)

    Thanks anyway,

    Diego
     

Share This Page