Relaying not allowed

Discussion in 'General' started by mphayesuk, May 11, 2006.

  1. mphayesuk

    mphayesuk Member

    I have set up Outlook Express with all the account settings which all work fine, when I try and send a message to one of my other accounts not part of ISPConfig I get:

    The message could not be sent because one of the recipients was rejected by the server. The rejected e-mail address was '[email protected]'. Subject 'Test', Account: 'pop.touchonehosting.co.uk', Server: 'smtp.touchonehosting.co.uk', Protocol: SMTP, Server Response: '554 <[email protected]>: Relay access denied', Port: 25, Secure(SSL): No, Server Error: 554, Error Number: 0x800CCC79

    Is there a setting somewhere in my mail config to allow this to go through.

    Thanks
     
  2. mphayesuk

    mphayesuk Member

    In my main.cf file I have a line "relayhosts = " does something need to be after the = sign.

    Thanks
     
  3. Norman

    Norman Member

    ISPConfig uses Saslauthentication, you need to setup exchange to authenticate with SMTP to be able to relay outside your own server.

    smtprelay = means a server which the postfix MTA will use to deliver all mail to and let to handle maildelivery for outgoing networks.

    What you are looking for would be
    mynetworks = 127.0.0.1/32

    means it will accept anything from localhost
    add more networks if you want to allow them without authentication
    mynetworks = 127.0.0.1/32, 213.122.112.0/24
    would allow any ip on 213.112.112.0 subnet.
     
  4. mphayesuk

    mphayesuk Member

    I want to only allow authenticated users to relay messages to other domains from outside the current domain.

    If you know what I mean.
     
  5. falko

    falko Super Moderator ISPConfig Developer

    You must enable "Server requires authentication." in your email client, that's all.
     

Share This Page