relaying denied from your location

Discussion in 'Installation/Configuration' started by gabykh, Jul 17, 2007.

  1. gabykh

    gabykh New Member

    Hi All ...
    I have centos 4.4 box with ispconfig Version: 2.2.12 and webmail i use postfix and RoundCube
    My problem is that i can send mails to outside .. just i cant receve mails from outside ..
    when i try to send from gmail . msn . yahoo.. to my mail .. i get :
    PERM_FAILURE: SMTP Error (state 13): 553 sorry, relaying denied from your location
    any idea how to fix that ?!
    Thanks
     
  2. gabykh

    gabykh New Member

    Hey ? any one can help ?!
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Any errors in the mail log, when you send a email from gmail?
     
  4. gabykh

    gabykh New Member

    Thanks for your reply

    where can i fined the mail log
     
    Last edited: Jul 18, 2007
  5. falko

    falko Super Moderator ISPConfig Developer

    I think it'S /var/log/maillog (or similar) on CentOS.
    Also post the output of
    Code:
    postconf -n
     
  6. gabykh

    gabykh New Member

    postconf -n output

    no errors in maillog

    and this is my postconf

    [[email protected] root]# postconf -n
    alias_database = hash:/etc/aliases
    alias_maps = hash:/etc/aliases
    broken_sasl_auth_clients = yes
    command_directory = /usr/sbin
    config_directory = /etc/postfix
    daemon_directory = /usr/libexec/postfix
    debug_peer_level = 2
    home_mailbox = Maildir/
    html_directory = no
    inet_interfaces = all
    mail_owner = postfix
    mailq_path = /usr/bin/mailq.postfix
    manpage_directory = /usr/share/man
    mydestination = $myhostname localhost.$mydomain localhost $mydomain
    mydomain = egeder.com
    myhostname = www.egeder.com
    mynetworks = 127.0.0.0/8
    myorigin = $mydomain
    newaliases_path = /usr/bin/newaliases.postfix
    queue_directory = /var/spool/postfix
    readme_directory = /usr/share/doc/postfix-2.1.5/README_FILES
    relay_domains =
    sample_directory = /usr/share/doc/postfix-2.1.5/samples
    sendmail_path = /usr/sbin/sendmail.postfix
    setgid_group = postdrop
    smtp_tls_note_starttls_offer = yes
    smtp_use_tls = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_local_domain =
    smtpd_sasl_security_options = noanonymous
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_auth_only = no
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    smtpd_use_tls = yes
    tls_random_source = dev:/dev/urandom
    unknown_local_recipient_reject_code = 550
     
    Last edited: Jul 18, 2007
  7. gabykh

    gabykh New Member

    any solutions guys ?!
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Please add the following two lines at the end of the file /etc/postfix/main.cf and restart postfix:

    Code:
    virtual_maps = hash:/etc/postfix/virtusertable
    mydestination = /etc/postfix/local-host-names
     
  9. gabykh

    gabykh New Member

    thanks till .. i did what you say ..
    and stell having this msg when im sending from gmail

    This is an automatically generated Delivery Status Notification

    Delivery to the following recipient failed permanently:

    [email protected]

    Technical details of permanent failure:
    PERM_FAILURE: SMTP Error (state 13): 553 sorry, relaying denied from your location [64.233.166.177] (#5.7.1)
     
  10. falko

    falko Super Moderator ISPConfig Developer

    Code:
    mh1:~# dig mx egeder.com
    
    ; <<>> DiG 9.2.1 <<>> mx egeder.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 6833
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;egeder.com.                    IN      MX
    
    ;; ANSWER SECTION:
    egeder.com.             3600    IN      MX      0 smtp.secureserver.net.
    egeder.com.             3600    IN      MX      10 mailstore1.secureserver.net.
    
    ;; ADDITIONAL SECTION:
    mailstore1.secureserver.net. 1067 IN    A       64.202.166.11
    
    ;; Query time: 229 msec
    ;; SERVER: 213.191.92.84#53(213.191.92.84)
    ;; WHEN: Thu Jul 19 14:00:52 2007
    ;; MSG SIZE  rcvd: 108
    
    mh1:~#
    You must change the MX record for your domain so that it points to your mail server (I doubt that the secureserver.net mail servers are yours).
     
  11. gabykh

    gabykh New Member

    i have update my MX record and now i can send from gmail and see no errors .
    the problem is that i cant see any msg coming in ?!
    how to fix that ?
    Thanks for helping me .
     
    Last edited: Jul 19, 2007
  12. gabykh

    gabykh New Member

    please can anyone help
     
  13. falko

    falko Super Moderator ISPConfig Developer

    Can you send a mail to your server and at the same time check the mail log? Do you see any action then?
    What's the output of
    Code:
    netstat -tap
    ?
     

Share This Page