Relayhost no longer disables

Discussion in 'Installation/Configuration' started by aldo, Feb 14, 2013.

  1. aldo

    aldo Member HowtoForge Supporter

    After enabling relayhost for a test (System, Server Config, Mail) even if I disable it (leaving relayhost, relayhost User, Password relayhost empty) it seems that the relayng continue.

    Even reboot solved.

    How do I disable relay?

    Thanks.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    remove it from main.cf and then restart postfix.
     
  3. aldo

    aldo Member HowtoForge Supporter

    Thank you.

    main.cf was already clean.

    Restarted postfix but seems unresolved

    The queue is not empty.
     
  4. aldo

    aldo Member HowtoForge Supporter

    Mmmm! One moment!

    The problem only happens to the same domain.

    Let me explain.

    The servers that has problems is called xyz.domain1.tld and the problem occurs only if the recipient is @domain1.tld all recipients with different domain have no problems.
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Most likely you have somwere domain1.tld in /etc/postfix/main.cf or /etc/mailname. Change all occurrences from domain1.tld to xyz.domain1.tld.
     
  6. aldo

    aldo Member HowtoForge Supporter

    Thank you Till.

    /etc/postfix/main.cf and /etc/mailname was clean (no occurrences of domain1.tld).

    I found
    mail.domain1.tld smtp_user:smtp_password
    in /etc/postfix/sasl_passwd
    that was exactly what set for hostrelay.

    Should I remove it?
     
  7. aldo

    aldo Member HowtoForge Supporter

    I tried to empty /etc/postfix/sasl_passwd and seems to solve the problem.
     
  8. aldo

    aldo Member HowtoForge Supporter

    In a new similar case I also had to:

    Code:
    cd /etc/postfix
    postmap hash:/etc/postfix/sasl_passwd
    service postfix restart
    this because despite having emptied the ISPConfig3 configuration related fields and the file /etc/postfix/sasl_passwd, postfix continued to relay undaunted.

    Maybe something does not reset as it should in my installations.
     
    Last edited: Nov 18, 2013

Share This Page