Relay SMTP problem

Discussion in 'Installation/Configuration' started by mickeb, Oct 17, 2007.

  1. mickeb

    mickeb New Member

    Hi i have worked 5 hours to get this work...

    I have Outlook. I want send mail from it. IMAP connection is OK but Sending mail it get a error: Coulnt not connect to host.

    I have:
    1. Added ports in Firewall (SMTP SSL port: 465) And checked if port 25 was addded.
    I have run netstat

    No results found

    and i did this also:

    shoudlnt SMTP be listning similar like apache?
    If i do
    I found by searching the forum how you could add 465port SMTP SSL but i dont know exactly how to do this in the file, or is it other file if you use debian etch?

    But there is a problem i tried to remove the # but postfix made a error in mail.err
    so i added # back.

    I made a external TELNET test on port 25, 465 and it returned could not find host.

    I made a NMAP test also and it didnt find 25, 465 port open, even though i opened them in the ISPCONFIG->management ->services->firewall:
    Hehe how do i solve this anyone got or had similuar problems?

    Humble regards Mike
  2. mickeb

    mickeb New Member

    Nmap result

    21/tcp open ftp
    22/tcp open ssh
    53/tcp open domain
    80/tcp open http
    81/tcp open hosts2-ns
    110/tcp open pop3
    143/tcp open imap
    443/tcp open https
    993/tcp open imaps
    995/tcp open pop3s

    why it dont show smtp?

    Greetings Mike
  3. falko

    falko Super Moderator ISPConfig Developer

    Comment out this part:
    #smtps inet n - - - - smtpd
    # -o smtpd_tls_wrappermode=yes
    # -o smtpd_sasl_auth_enable=yes
    # -o smtpd_client_restrictions=permit_sasl_authenticate d,reject
    so that it looksl ike this:
    smtps inet n - - - - smtpd
     -o smtpd_tls_wrappermode=yes
     -o smtpd_sasl_auth_enable=yes
     -o smtpd_client_restrictions=permit_sasl_authenticate d,reject
    Restart Postfix then.
  4. mickeb

    mickeb New Member

    Yes i did!

    Thank you so much

    regards mike
  5. fsoyer

    fsoyer New Member

    Hello all,
    hello and thanks for work, Falko (and for so many answers on this forum, too :p !)

    I have installed ISPConfig on an Etch with the, and it works fine.

    Just this %!@#! smtp authentication....
    After hours of research on the forum, I got it, so let me resume (hum hum, I'm afraid of not be able to do it short...) !

    With this tuto, once the server has been set as MX for a domain, it receive mails for existing users (and aliases), and reject unknown recipients : good.
    I had no real problem to use POP(S) and IMAP(S) for reading mails, just think to :
    - check "Maildir" on ISPConfig admin/parameters/e-mail page, to avoid "chdir Maildir : not such file or directory" messages on server
    - add right lines and ports in the ISPConfig firewall (admin->services->firewall) if enabled (respectively ports 25, 110, 995, 143 and/or 993).
    I had no problem too for sending mail from the server itself.

    The problem comes when I want to send mail through this server from a remote mail client (Evolution on my laptop).
    First, no way to connect to the server with standard smtp. The first two hours of searchs and tests to find... that this is blocked by my ISP to avoid spams ! So the port 25 is used for MTA to MTA discuss (so it must be enabled on the server), but is used too for MUAs to MTA transfers, and that is blocked by ISPs (am I right ?).
    Ok. After all, why not, spam is bad. Bouh.

    So I try with SSL. The SMTPS port is 465, open it on firewall, blah blah blah.
    Evolution is set to join the server with smtp on SSL, but first say "enable to connect to server". Finally, I noticed with a "nmap localhost" on server that Postfix was not listening on port 465, only 25.
    The modification (smpts line) is the truth ! However, though the connect error is solved, nothing happened. Evolution is waiting and never ask for a password, and no messages on server except "postfix/smtpd[23942]: connect from xxxxx" then it fall in timeout.
    Another hour to find that I had not commented out the option line of smtps (" -o smtpd_tls_wrappermode=yes") in !
    Argh. But what a @!#?% !!!

    So I can use ISPConfig installation and users as SMTP and Imaps/pops server. Pfooo !

    Just note that the two last lines ("smtpd_sasl_auth_enable" and "smtpd_client_restrictions") are not necessary, since there are already in

    So, however some questions come to me :
    1. Maybe the modification can be added to the Perfect setup, to avoid some other nightmares ?...
    2. With Evolution I must check "use Maildir" on server in order to read mail. Is this necessary with others mail clients (Outlook, thunderbird...) ? And is Maildir format OK for this clients ? Not tested.
    3. Which difference between TLS and SSL ? Evolution has this two options, but when I try "SMTP with TLS", it says "I/O error"... Some idea of why ? And how it works ?

    Thanks again.
  6. falko

    falko Super Moderator ISPConfig Developer

    Are you using IMAP? Because I can't remember enabling Maildir in any email client with POP3.
  7. fsoyer

    fsoyer New Member

    I have tried with POP and IMAP. Same message on server : " courierpop3login: chdir Maildir: No such file or directory" and " imapd: chdir Maildir: No such file or directory".

    But maybe the problem is the client (Evolution) ?
    Next week I'll try with other clients, with and without Maildir.

    Happy end of year :D
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Please make sure that you have the maildir checkbox enabled in ISPConfig under management > server > settings and that you sent a email to the account first.

Share This Page