Relay email on a postfix server problem

Discussion in 'General' started by pinguinito, May 27, 2010.

  1. pinguinito

    pinguinito New Member

    This is my out put from "Show Mail Error-log":

    May 27 00:49:20 server1 postfix/qmgr[4204]: 2571973A76: from=<>, status=expired, returned to sender
    May 27 00:49:20 server1 postfix/qmgr[4204]: 2571973A76: removed
    May 27 00:49:22 server1 postfix/pickup[16321]: 40B10B34F6: uid=33 from=
    May 27 00:49:22 server1 postfix/cleanup[16515]: 40B10B34F6: message-id=<20100527044922.40B10B34F6@server1.example.com>
    May 27 00:49:22 server1 postfix/qmgr[4204]: 40B10B34F6: from=, size=916, nrcpt=1 (queue active)
    May 27 00:49:23 server1 postfix/smtpd[16521]: connect from localhost.localdomain[127.0.0.1]
    May 27 00:49:23 server1 postfix/smtpd[16521]: 0C288B34F9: client=localhost.localdomain[127.0.0.1]
    May 27 00:49:23 server1 postfix/cleanup[16515]: 0C288B34F9: message-id=<20100527044922.40B10B34F6@server1.example.com>
    May 27 00:49:23 server1 postfix/smtpd[16521]: disconnect from localhost.localdomain[127.0.0.1]
    May 27 00:49:23 server1 amavis[3336]: (03336-14) Passed BAD-HEADER, -> , quarantine: P/badh-Pm04lyfa34gV, Message-ID: <20100527044922.40B10B34F6@server1.example.com>, mail_id: Pm04lyfa34gV, Hits: 0.476, size: 916, queued_as: 0C288B34F9, 652 ms
    May 27 00:49:23 server1 postfix/smtp[16518]: 40B10B34F6: to=, relay=127.0.0.1[127.0.0.1]:10024, delay=1, delays=0.34/0.03/0.01/0.65, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=03336-14, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 0C288B34F9)
    May 27 00:49:23 server1 postfix/qmgr[4204]: 40B10B34F6: removed
    May 27 00:49:23 server1 postfix/qmgr[4204]: 0C288B34F9: from=, size=1523, nrcpt=1 (queue active)
    May 27 00:49:23 server1 postfix/error[16523]: 0C288B34F9: to=, relay=none, delay=0.19, delays=0.08/0.01/0/0.09, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to smtp.1and1.com[74.208.5.2]:583: Connection timed out)
    May 27 00:50:01 server1 pop3d: Connection, ip=[::ffff:127.0.0.1]
    May 27 00:50:01 server1 pop3d: Disconnected, ip=[::ffff:127.0.0.1]
    May 27 00:50:01 server1 imapd: Connection, ip=[::ffff:127.0.0.1]
    May 27 00:50:01 server1 imapd: Disconnected, ip=[::ffff:127.0.0.1], time=0

    The email did not arrive to the destination.
    Can some one see what the error is?

    thanks to all of you.
     
  2. till

    till Super Moderator

    Please check if you have enabled quarantining for bad header checks in the amavisd spamfilter policy in ispconfig or in the amavisd.conf file. You should set bad header to pass.
     
  3. pinguinito

    pinguinito New Member

    Relay email on a pastfix server problem

    Hi I change in my policy as you said. thank for that

    but I have and email error:

    May 27 00:13:41 server1 postfix/postmap[15736]: fatal: usage: postmap [-Nfinoprsvw] [-c config_dir] [-d key] [-q key] [map_type:]file...

    server is Relay to other SMTP server
     
    Last edited: May 28, 2010
  4. falko

    falko Super Moderator

    Did you run postmap manually?
     
  5. pinguinito

    pinguinito New Member

    Relay email on a pastfix server problem

    postmap /etc/postfix/saslpasswd

    This is how I used postmap and them:

    /etc/init.d/postfix restart
     
  6. falko

    falko Super Moderator

  7. pinguinito

    pinguinito New Member

    Relay smtp server problem

    Hi falco:

    This is the out put after your your recommendation:


    Jun 4 00:39:25 server1 postfix/smtpd[11694]: disconnect from localhost.localdomain[127.0.0.1]
    Jun 4 00:39:26 server1 amavis[2107]: (02107-02) Passed BAD-HEADER, <webmaster@example.com> -> <example@rogers.com>, quarantine: B/badh-BBzk$
    Jun 4 00:39:26 server1 postfix/smtp[11691]: 54842B34F6: to=<example@rogers.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=3.8, delays=0.24/$
    Jun 4 00:39:26 server1 postfix/qmgr[11370]: 54842B34F6: removed
    Jun 4 00:39:26 server1 postfix/smtp[11695]: 8FCA173953: to=<example@rogers.com>, relay=smtp.gmail.com[74.125.113.109]:587, delay=0.77, del$
    Jun 4 00:39:26 server1 postfix/cleanup[11688]: 7F9CFB34F6: message-id=<20100604043926.7F9CFB34F6@server1.example.com>
    Jun 4 00:39:26 server1 postfix/bounce[11696]: 8FCA173953: sender non-delivery notification: 7F9CFB34F6
    Jun 4 00:39:26 server1 postfix/qmgr[11370]: 8FCA173953: removed
    Jun 4 00:39:26 server1 postfix/qmgr[11370]: 7F9CFB34F6: from=<>, size=3555, nrcpt=1 (queue active)
    Jun 4 00:39:26 server1 postfix/smtp[11695]: 7F9CFB34F6: to=<webmaster@example.com>, relay=smtp.gmail.com[74.125.113.109]:587, delay=0.3, del$
    Jun 4 00:39:26 server1 postfix/qmgr[11370]: 7F9CFB34F6: removed
    Jun 4 00:40:01 server1 postfix/smtpd[11728]: connect from localhost.localdomain[127.0.0.1]
    Jun 4 00:40:01 server1 postfix/smtpd[11728]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
    Jun 4 00:40:01 server1 postfix/smtpd[11728]: disconnect from localhost.localdomain[127.0.0.1]
    Jun 4 00:45:02 server1 postfix/smtpd[11820]: connect from localhost.localdomain[127.0.0.1]
    Jun 4 00:45:02 server1 postfix/smtpd[11820]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
    Jun 4 00:45:02 server1 postfix/smtpd[11820]: disconnect from localhost.localdomain[127.0.0.1]
    Jun 4 00:50:01 server1 postfix/smtpd[11912]: connect from localhost.localdomain[127.0.0.1]
    Jun 4 00:50:01 server1 postfix/smtpd[11912]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
    Jun 4 00:50:01 server1 postfix/smtpd[11912]: disconnect from localhost.localdomain[127.0.0.1]

    I appreciate your help, time and dedication

    sincerely

    pinguinito
     

Share This Page