relay domain + Spam filter + Local postbox

Discussion in 'Installation/Configuration' started by carg, Aug 30, 2010.

  1. carg

    carg New Member

    Hi,

    I'm using latest version of Ispconifg 3.

    This is what I have:
    Scanning for viruses + spam
    Relay Email Domain to Customers SMTP (Customer has own SMTP host)

    This what I like to have:
    Scanning for viruses + spam
    if spam or Virus-> put to local mailbox (doesn't need to be customers Domain - just a specific mailbox)
    Relay Email Domain to Customers SMTP

    Is such a setup possible? And if howto?

    Many thanks for any hint

    Patrick
     
    Last edited: Aug 30, 2010
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Create records for the email addresses or email domains of the forwarded accounts in ispconfig under email > spamfilter > user/domain

    Then edit the spamfilter policy that you selected for this email address or domain and enter the target email address for the spam emails in the field "Forward spam to email".
     
  3. carg

    carg New Member

    Hi Till,

    many thanks for the answer - sometimes it's simple BUT
    the forwarding is not working. The subject is marked as spam (I set the Spam values to -9) but delivered normal way. It should get forwared to the account given at the filter. In maillog I can see that it gets normal out which it should not as the forward address is a local postbox (spam@somedomain.com).
    Any idea where to look at?

    Cheers, Patrick
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Enable debugging in amavisd and then check which rules get applied and if your plicy gets selected for a specific email. See amavisd.conf or the 50-user file on debian / ubuntu for log level settings.
     
  5. carg

    carg New Member

    Hi,

    after switching the level to 5 (btw. bad idea to have the same variable 2 times in the same script -> last one matches ..) the sql showed me that it has the right rule: policy_name=>"Spambox". All the settings are from that rule like subject rewrite etc. I can see that the email where to forward the mail to is there as well. (spam_quarantine_to=>"spam-admin@spamadmindomain.com" )
    spam_tag_level=>"-10", spam_tag2_level=>"-5" this makes sure that more or less every email will be spam (good for testing). The email get the spam header + subject etc. etc.
    Everything is looking fine but the last rewrite to the "spam-admin" email I can't see anywhere.
    Code:
    ----
    lookup [spam_subject_tag2] => true,  "support@todomain.zz" matches, result="*S _SCORE_* X", matching_key="/cached/"
    headers CLUSTERING: NEW CLUSTER <support@todomain.zz>: score=0.1, tag=1, tag2=1, local=1, bl=, s=*S 0.1* X, mangle=
    header: X-Virus-Scanned: amavisd-new at co4.mailhost.zz\n
    header: X-Spam-Flag: YES\n
    header: X-Spam-Score: 0.1\n
    header: X-Spam-Level: \n
    header: X-Spam-Status: Yes, score=0.1 tagged_above=-10 required=-5\n\ttests=[RDNS_NONE=0.1] autolearn=no\n
    header: Received: from co4.mailhost.zz ([127.0.0.1])\n\tby localhost (co4.mailhost.zz [127.0.0.1]) (amavisd-new, port 10024)\n\twith ESMTP id i51hHhuKsDOr for <support@todomain.zz>;\n\tTue, 31 Aug 2010 14:56:36 +0200 (CEST)\n
    headers CLUSTERING: done all 1 recips in one go
    SPAM-TAG, <a@fromdomain.zz> -> <support@todomain.zz>, Yes, score=0.1 tagged_above=-10 required=-5 tests=[RDNS_NONE=0.1] autolearn=no
    (about to connect to [127.0.0.1]:10025) FWD via SMTP: <a@fromdomain.zz> -> <support@todomain.zz>
    ----
    
    Can you point my nose where I should look at please?

    Cheers, Patrick

    ps.: found this http://howtoforge.net/forums/showthread.php?p=238105 same problem
     
    Last edited: Aug 31, 2010
  6. carg

    carg New Member

    Hi,

    I installed a fresh Debian + ISPconfig 3
    the forward is not working there as well.

    Any further ideas?

    Cheers, Patrick
     

Share This Page