relay access denied

Discussion in 'Installation/Configuration' started by torusturtle, Nov 28, 2006.

  1. torusturtle

    torusturtle ISPConfig Developer ISPConfig Developer

    Hello

    I moved ISPConfig to a new server but do now have Problems with the smtp.
    When sending emails I get the error message relay access denied.

    I checked /etc/postfix/local-host-names and /etc/postfix/main.cf they seem to be in order.

    main.cf
    Code:
    queue_directory = /var/spool/postfix
    command_directory = /usr/sbin
    daemon_directory = /usr/libexec/postfix
    mail_owner = postfix
    unknown_local_recipient_reject_code = 550
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    debugger_command =
             PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
             xxgdb $daemon_directory/$process_name $process_id & sleep 5
    
    sendmail_path = /usr/sbin/sendmail.postfix
    newaliases_path = /usr/bin/newaliases.postfix
    mailq_path = /usr/bin/mailq.postfix
    setgid_group = postdrop
    html_directory = no
    manpage_directory = /usr/share/man
    sample_directory = /usr/share/doc/postfix-2.2.2/samples
    readme_directory = /usr/share/doc/postfix-2.2.2/README_FILES
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_tls_auth_only = yes
    smtp_use_tls = yes
    smtpd_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    
    virtual_maps = hash:/etc/postfix/virtusertable
    
    mydestination = /etc/postfix/local-host-names
    
    maillog
    Code:
    Nov 28 09:22:26 server1 postfix/smtpd[14229]: NOQUEUE: reject: RCPT from 39-42-20-160.dclient.hispeed.ch[39.42.20.160]: 554 <[email protected]>: Relay access denied; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<[127.0.0.1]>
    
    local-host-names
    Code:
    ###################################
    #
    # ISPConfig local-host-names Configuration File
    #         Version 1.0
    #
    ###################################
    localhost
    server1.mydomain.tld
    localhost.server1.mydomain.tld
    localhost.mydomain.tld
    localhost.localdomain
    www.mydomain.tld
    mydomain.tld
    

    DNS (not in ISPConfig)
    post-install first-install-reminder gives the following
    But I never had to do that in previous ISPConfig installations.


    Any help is appreciated.
    Thanks
     
    Last edited: Oct 14, 2007
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please add these lines to your main.cf file:

    mynetworks = 127.0.0.0/8
    myorigin = /etc/mailname

    and restart postfix. Make also sure that the file /etc/mailname contains the hostname (fqdn) of your server.
     
  3. torusturtle

    torusturtle ISPConfig Developer ISPConfig Developer

    I added the above to main.cf and created /etc/mailname where I inserted the following
    Unfortunately doesn't work.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    /etc/mailname shall contain just one line. I guess it must be hexo.kynamoo.ch in your case.

    Do you try to send this email from webmail or a normal mailclient like thunderbird / outlook?
     
  5. torusturtle

    torusturtle ISPConfig Developer ISPConfig Developer

    Hi Till

    It doesn't work with neither hexo.kynamoo.ch nor kynamoo.ch.

    I use Thunderbird 1.5.

    Sending with roundcubemail does work.
     
  6. Hans

    Hans Moderator ISPConfig Developer

    Is your IP-address set correctly within ISPConfig?
    Roundcube uses "localhost" as the host/domain which is always correct.

    What is the output of your hostname -f ?
     
  7. falko

    falko Super Moderator ISPConfig Developer

    Please enable "Server requires authentication." (or similar) in your email client.
     

Share This Page