Relay access denied

Discussion in 'Installation/Configuration' started by danhansen@denmark, Apr 20, 2013.

  1. danhansen@denmark

    danhansen@denmark HowtoForge Supporter

    Hi,

    Will try to keep it simple.
    Anybody who knows the solution to this warning in the mail-log?

    Apr 19 15:27:35 server1 postfix/smtpd[17196]: connect from mail-ee0-f46.google.com[74.125.83.46]
    Apr 19 15:27:36 server1 postfix/smtpd[17196]: NOQUEUE: reject: RCPT from mail-ee0-f46.google.com[74.125.83.46]: 554 5.7.1 <postmaster@domain.dk>: Relay access denied; from=<mail@gmail.com> to=<postmaster@domain.dk> proto=ESMTP helo=<mail-ee0-f46.google.com>
    Apr 19 15:27:36 server1 postfix/smtpd[17196]: disconnect from mail-ee0-f46.google.com[74.125.83.46]


    Mailserver received mails for 5 minutes and then stopped receiving. Emails bounce "back to sender" :confused:

    Please help:eek:
     
  2. markc

    markc New Member

    Hi Dan, make sure you have something like this in your postfix main.cf...
    Code:
    ~ grep smtpd_recipient_restrictions /etc/postfix/main.cf
    smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, reject_unauth_destination
     
  3. danhansen@denmark

    danhansen@denmark HowtoForge Supporter

    Relay access denied - /etc/postfix/main.cf

    Hi Mark ;)


    Thanks for you help ...

    But, is these restrictios something you can set in the ISPconfig CP? Or do I have to do it the old fashion way ;)

    I have gathered some settings here - with help from johnny Chadda from the other side of the border, in sweden ;) Here's the links to some postfix knowhow:
    http://johnny.chadda.se/article/mail-server-howto-postfix-and-dovecot-with-mysql-and-tlsssl-postgrey-and-dspam/

    Code:
    [B]Postfix RBL and other rules[/B]
    
    smtpd_recipient_restrictions =
    permit_mynetworks
    permit_tls_all_clientcerts
    #permit_sasl_authenticated
    reject_non_fqdn_hostname
    reject_non_fqdn_sender
    reject_non_fqdn_recipient
    reject_unauth_destination
    reject_unauth_pipelining
    reject_invalid_hostname
    #reject_unknown_sender_domain
    #reject_unknown_hostname
    reject_rbl_client zen.spamhaus.org
    reject_rbl_client bl.spamcop.net
    reject_rbl_client cbl.abuseat.org
    reject_rbl_client dnsbl.njabl.org
    reject_rbl_client dnsbl.sorbs.net
    reject_rhsbl_sender dsn.rfc-ignorant.org
    check_policy_service inet:127.0.0.1:60000
    permit
    #
    smtpd_data_restrictions =
    reject_unauth_pipelining,
    reject_multi_recipient_bounce,
    permit
    
    what say you mr. C
    Can any of the above be used along with your suggestion? Been reading and writing all night, so I have to know.

    Sorry for being a completely nobrain.. I'm no Postfix Professor, I know it!

    I noiced that the RBL I entered in the ISPconfic CP "System > Server Config > Mail" is shown in the /etc/postfix/main.cf as shown beneath:

    smtpd_recipient_restrictions = permit_mynetworks, reject_unauth_destination, reject_rbl_client zen.spamhaus.org

    So apparently you can enter the information in ISPconfig CP - But can you enter it all there?
     
    Last edited: Apr 20, 2013
  4. markc

    markc New Member

    Just edit /etc/postfix/main.cf directly with whatever is the minimum to allow your mailserver to work as expected. Once it works then any amount of fiddling and fine tuning can be applied afterwards. The line I posted works for me so compare yours with it and make sure there isn't a glaring or obvious omission in your main.cf.

    There are some great hints in that Johnny Chadda link you posted, thanks for that :)
     
  5. danhansen@denmark

    danhansen@denmark HowtoForge Supporter

    Enter it directly!

    Hi Mark,

    Thanks for that! I just made a backup file and are doing your command...
    And yes, you are right, other stuff can be added later on!

    Here is the result after editing the /etc/postfix/main.cf directly - hope it works and that other novices like me can use this:

    relayhost =
    smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, reject_unauth_destination, reject_rbl_client zen.spamhaus.org
    mailbox_size_limit = 0
    message_size_limit = 0



    Thanks again Mark ;)
     
    Last edited: Apr 20, 2013
  6. danhansen@denmark

    danhansen@denmark HowtoForge Supporter

    Still no mail - relay access denied, but?

    Hi Mark,

    Stil no mail.. It bounces instantly! Here's the stuff from the mail-log:

    Apr 20 17:55:39 server1 postfix/smtpd[6892]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
    Apr 20 17:55:39 server1 postfix/smtpd[6892]: connect from mail-we0-f180.google.com[74.125.82.180]
    Apr 20 17:55:39 server1 postfix/smtpd[6895]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
    Apr 20 17:55:39 server1 postfix/smtpd[6892]: NOQUEUE: reject: RCPT from mail-we0-f180.google.com[74.125.82.180]: 554 5.7.1 <postmaster@domain.dk>: Relay access denied; from=<mail@gmail.com> to=<postmaster@domain.dk> proto=ESMTP helo=<mail-we0-f180.google.com>


    Could it be beacause of the warning? Its just that its a "warning" and not an "error":

    warning: dict_nis_init: NIS domain name not set

    And I did restart postfix ;)
     
  7. danhansen@denmark

    danhansen@denmark HowtoForge Supporter

    Mailbox Spamfilter settings ISPconfig CP

    Hi,

    It just keeps getting on and on..

    I tried setting spamfiler rules in the ISPconfig CP but still no luck..

    Code:
    Apr 20 18:22:24 server1 postfix/smtpd[2865]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
    Apr 20 18:22:24 server1 postfix/smtpd[2867]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
    Apr 20 18:22:24 server1 postfix/smtpd[2337]: connect from mail-wi0-f177.google.com[209.85.212.177]
    Apr 20 18:22:24 server1 postfix/smtpd[2867]: connect from mail-wi0-f169.google.com[209.85.212.169]
    Apr 20 18:22:24 server1 postfix/smtpd[2337]: NOQUEUE: reject: RCPT from mail-wi0-f177.google.com[209.85.212.177]: 554 5.7.1 <postmaster@domain.dk>: Relay access denied; from=<mail@gmail.com> to=<postmaster@domain.dk> proto=ESMTP helo=<mail-wi0-f177.google.com>
    Apr 20 18:22:24 server1 postfix/smtpd[2337]: disconnect from mail-wi0-f177.google.com[209.85.212.177]
    Apr 20 18:22:24 server1 postfix/smtpd[2867]: NOQUEUE: reject: RCPT from mail-wi0-f169.google.com[209.85.212.169]: 554 5.7.1 <postmaster@domain.dk>: Relay access denied; from=<mail@gmail.com> to=<postmaster@domain.dk> proto=ESMTP helo=<mail-wi0-f169.google.com>
    Apr 20 18:22:24 server1 postfix/smtpd[2867]: disconnect from mail-wi0-f169.google.com[209.85.212.169]
    Apr 20 18:22:24 server1 postfix/smtpd[2865]: connect from mail-we0-f171.google.com[74.125.82.171]
    Apr 20 18:22:24 server1 postfix/smtpd[2865]: NOQUEUE: reject: RCPT from mail-we0-f171.google.com[74.125.82.171]: 554 5.7.1 <postmaster@domain.dk>: Relay access denied; from=<mail@gmail.com> to=<postmaster@domain.dk> proto=ESMTP helo=<mail-we0-f171.google.com>
    Apr 20 18:22:24 server1 postfix/smtpd[2865]: disconnect from mail-we0-f171.google.com[74.125.82.171]
    
    Remember, after the port 25 were opened from the ISP all mails went trough for a short time, and then just stopped! I didn't change anything at all. And this warning appered to:

    warning: dict_nis_init: NIS domain name

    Any ideas?
     
  8. markc

    markc New Member

    The next thing to check is this...

    check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf

    so add this to your /etc/mysql/my.cnf files under the [mysqld] sections...

    general_log = 1
    general_log_file = /var/log/mysql/mysql.log


    and tail -f /var/log/mysql/mysql.log while a message comes in/ What you are looking for is the EXACT mysql query which is defined in the mysql-virtual_recipient.cf file (cat the file to see it).

    Once you see the log entry for, say, postmaster then ctrl-c out of tailing the log file and at the prompt type...

    mysql -e "PASTE THE ENTIRE QUERY FROM THE MYSQL LOG FILE HERE;"

    and that will either successfuly return a correct lookup... or give you an error as to why it failed, which could be as simple as the server_id field being wrong.
     
  9. markc

    markc New Member

    As for the NIS lookup warning, the goog found this...

    It's a warning, not an error. You eliminate it by removing NIS lookups.

    First, find out what setting is using NIS:

    $ postconf | grep nis:

    This outputs something like

    alias_maps = hash:/etc/aliases nis:mail.aliases

    or

    alias_maps = hash:/etc/mail/aliases nis:mail.aliases

    Then, disable NIS lookups (as root):

    # postconf -e alias_maps=hash:/etc/aliases

    or

    # postconf -e alias_maps=hash:/etc/mail/aliases

    The exact command depends on "postconf | grep nis:" output.

    Wietse

    ***

    And here is another comment that explains why a bit better...

    First of I didn’t ask postfix to do NIS lookups. These warning messages started showing up when I commented out alias_maps and decided to only use alias_database instead. The fix was simple.

    alias_maps when commented, uses the default settings:
    alias_maps = hash:/etc/aliases, nis:mail.aliases

    This allows postfix to work even without explicit alias_maps settings. However the default also encumbers it with checking nis. Setting alias_maps explicitly eliminates the problem:

    alias_maps = hash:/etc/aliases
     
    Last edited: Apr 20, 2013
  10. danhansen@denmark

    danhansen@denmark HowtoForge Supporter

    I'm lost...

    Hi Mark,

    I'm lost.. Under the SQL section you say...

    Sorry :eek:
     
  11. danhansen@denmark

    danhansen@denmark HowtoForge Supporter

    Fixed the problem: warning: dict_nis_init: NIS domain name not set - NIS lookups disa

    Hi,

    The goog says - that took care of business!
    It looks like its gone - we nailed that one, didn.t we? :)

    Thanks for that Mark,

    Hope to see you shine regarding that other issue as well :D
    http://www.howtoforge.com/forums/showthread.php?p=296089#post296089
     
    Last edited: Apr 20, 2013
  12. danhansen@denmark

    danhansen@denmark HowtoForge Supporter

    So far so good...

    Hi Mark,

    After making a backup of the original file "/etc/mysql/my.cf" I made the changes you told me too:

    Code:
    [mysqld]
    #
    # * Basic Settings
    #
    
    #
    # * IMPORTANT
    #   If you make changes to these settings and your system uses apparmor, you may
    #   also need to also adjust /etc/apparmor.d/usr.sbin.mysqld.
    #
    
    user            = mysql
    socket          = /var/run/mysqld/mysqld.sock
    port            = 3306
    basedir         = /usr
    datadir         = /var/lib/mysql
    tmpdir          = /tmp
    general_log     = 1
    general_log_file = /var/log/mysql/mysql.log
    skip-external-locking
    
    
    But the rest you will have to provide me some details, "spell it out" you know :eek:

    And this:
    "IMPORTANT
    If you make changes to these settings and your system uses apparmor, you may
    also need to also adjust /etc/apparmor.d/usr.sbin.mysqld.


    Are all these errors due to the release upgrade I did? According to some, the ISPconfig 3 installation should work as a default installation!?

    Well, here's the mail-log after rebooting - theres some remarks regarding SQL:

    Code:
    Apr 20 20:06:10 server1 amavis[1186]: Module URI 1.59
    Apr 20 20:06:10 server1 amavis[1186]: Module Unix::Syslog 1.1
    Apr 20 20:06:10 server1 amavis[1186]: Amavis::DB code loaded
    Apr 20 20:06:10 server1 amavis[1186]: Amavis::Cache code loaded
    Apr 20 20:06:10 server1 amavis[1186]: SQL base code loaded
    Apr 20 20:06:10 server1 amavis[1186]: SQL::Log code NOT loaded
    Apr 20 20:06:10 server1 amavis[1186]: SQL::Quarantine NOT loaded
    Apr 20 20:06:10 server1 amavis[1186]: Lookup::SQL code loaded
    Apr 20 20:06:10 server1 amavis[1186]: Lookup::LDAP code NOT loaded
    Apr 20 20:06:10 server1 amavis[1186]: AM.PDP-in proto code loaded
    Apr 20 20:06:10 server1 amavis[1186]: SMTP-in proto code loaded
    Apr 20 20:06:10 server1 amavis[1186]: Courier proto code NOT loaded
    Apr 20 20:06:10 server1 amavis[1186]: SMTP-out proto code loaded
    Apr 20 20:06:10 server1 amavis[1186]: Pipe-out proto code NOT loaded
    Apr 20 20:06:10 server1 amavis[1186]: BSMTP-out proto code NOT loaded
    Apr 20 20:06:10 server1 amavis[1186]: Local-out proto code loaded
    Apr 20 20:06:10 server1 amavis[1186]: OS_Fingerprint code NOT loaded
    Apr 20 20:06:10 server1 amavis[1186]: ANTI-VIRUS code loaded
    Apr 20 20:06:10 server1 amavis[1186]: ANTI-SPAM code loaded
    Apr 20 20:06:10 server1 amavis[1186]: ANTI-SPAM-EXT code NOT loaded
    Apr 20 20:06:10 server1 amavis[1186]: ANTI-SPAM-C code NOT loaded
    Apr 20 20:06:10 server1 amavis[1186]: ANTI-SPAM-SA code loaded
    Apr 20 20:06:10 server1 amavis[1186]: Unpackers code loaded
    Apr 20 20:06:10 server1 amavis[1186]: DKIM code loaded
    Apr 20 20:06:10 server1 amavis[1186]: Tools code NOT loaded
    Apr 20 20:06:10 server1 amavis[1186]: Found $file at /usr/bin/file
    Apr 20 20:06:10 server1 amavis[1186]: No $altermime, not using it
    Apr 20 20:06:10 server1 amavis[1186]: Internal decoder for .mail
    Apr 20 20:06:10 server1 amavis[1186]: No decoder for .F
    Apr 20 20:06:10 server1 amavis[1186]: Found decoder for .Z at /bin/uncompress
    Apr 20 20:06:10 server1 amavis[1186]: Internal decoder for .gz
    Apr 20 20:06:10 server1 amavis[1186]: Found decoder for .bz2 at /bin/bzip2 -d
    Apr 20 20:06:10 server1 amavis[1186]: Found decoder for .lzo at /usr/bin/lzop -d
    Apr 20 20:06:10 server1 amavis[1186]: No decoder for .rpm tried: rpm2cpio.pl, rpm2cpio
    Apr 20 20:06:10 server1 amavis[1186]: Found decoder for .cpio at /bin/pax
    Apr 20 20:06:10 server1 amavis[1186]: Found decoder for .tar at /bin/pax
    Apr 20 20:06:10 server1 amavis[1186]: Found decoder for .deb at /usr/bin/ar
    Apr 20 20:06:10 server1 amavis[1186]: Internal decoder for .zip
    Apr 20 20:06:10 server1 amavis[1186]: No decoder for .7z tried: 7zr, 7za, 7z
    Apr 20 20:06:10 server1 amavis[1186]: No decoder for .rar tried: unrar-free
    Apr 20 20:06:10 server1 amavis[1186]: Found decoder for .arj at /usr/bin/arj
    Apr 20 20:06:10 server1 amavis[1186]: Found decoder for .arc at /usr/bin/nomarch
    Apr 20 20:06:10 server1 amavis[1186]: Found decoder for .zoo at /usr/bin/zoo
    Apr 20 20:06:10 server1 amavis[1186]: No decoder for .lha
    Apr 20 20:06:10 server1 amavis[1186]: No decoder for .doc tried: ripole
    Apr 20 20:06:10 server1 amavis[1186]: Found decoder for .cab at /usr/bin/cabextract
    Apr 20 20:06:10 server1 amavis[1186]: No decoder for .tnef
    Apr 20 20:06:10 server1 amavis[1186]: Internal decoder for .tnef
    Apr 20 20:06:10 server1 amavis[1186]: Found decoder for .exe at /usr/bin/arj
    Apr 20 20:06:10 server1 amavis[1186]: Using primary internal av scanner code for ClamAV-clamd
    Apr 20 20:06:10 server1 amavis[1186]: Found secondary av scanner ClamAV-clamscan at /usr/bin/clamscan
    Apr 20 20:06:10 server1 amavis[1186]: Creating db in /var/lib/amavis/db/; BerkeleyDB 0.49, libdb 5.1
    Apr 20 20:06:11 server1 spamd[1202]: logger: removing stderr method
    Apr 20 20:06:19 server1 spamd[1318]: spamd: server started on port 783/tcp (running version 3.3.2)
    Apr 20 20:06:19 server1 spamd[1318]: spamd: server pid: 1318
    Apr 20 20:06:19 server1 spamd[1318]: spamd: server successfully spawned child process, pid 1469
    Apr 20 20:06:19 server1 spamd[1318]: spamd: server successfully spawned child process, pid 1470
    Apr 20 20:06:19 server1 spamd[1318]: prefork: child states: II
    Apr 20 20:06:36 server1 authdaemond: modules="authmysql", daemons=5
    Apr 20 20:06:36 server1 authdaemond: Installing libauthmysql
    Apr 20 20:06:36 server1 authdaemond: Installation complete: authmysql
    Apr 20 20:06:38 server1 postfix/master[2075]: daemon started -- version 2.9.6, configuration /etc/postfix
    Apr 20 20:07:01 server1 pop3d: Connection, ip=[::ffff:127.0.0.1]
    Apr 20 20:07:01 server1 pop3d: Disconnected, ip=[::ffff:127.0.0.1]
    Apr 20 20:07:01 server1 imapd: Connection, ip=[::ffff:127.0.0.1]
    Apr 20 20:07:01 server1 imapd: Disconnected, ip=[::ffff:127.0.0.1], time=0
    Apr 20 20:07:02 server1 postfix/smtpd[2272]: connect from localhost[127.0.0.1]
    Apr 20 20:07:02 server1 postfix/smtpd[2272]: lost connection after CONNECT from localhost[127.0.0.1]
    Apr 20 20:07:02 server1 postfix/smtpd[2272]: disconnect from localhost[127.0.0.1]
    Apr 20 20:07:20 server1 imapd: Connection, ip=[::ffff:127.0.0.1]
    Apr 20 20:07:20 server1 imapd: LOGIN, user=postmaster@apollo1.dk, ip=[::ffff:127.0.0.1], port=[42185], protocol=IMAP
    Apr 20 20:07:21 server1 imapd: LOGOUT, user=postmaster@apollo1.dk, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=87, sent=392, time=1
    Apr 20 20:08:01 server1 postfix/smtpd[2272]: connect from localhost[127.0.0.1]
    Apr 20 20:08:01 server1 postfix/smtpd[2272]: lost connection after CONNECT from localhost[127.0.0.1]
    Apr 20 20:08:01 server1 postfix/smtpd[2272]: disconnect from localhost[127.0.0.1]
    Apr 20 20:08:01 server1 pop3d: Connection, ip=[::ffff:127.0.0.1]
    Apr 20 20:08:01 server1 pop3d: Disconnected, ip=[::ffff:127.0.0.1]
    Apr 20 20:08:01 server1 imapd: Connection, ip=[::ffff:127.0.0.1]
    Apr 20 20:08:01 server1 imapd: Disconnected, ip=[::ffff:127.0.0.1], time=0
    Apr 20 20:09:01 server1 postfix/smtpd[2272]: connect from localhost[127.0.0.1]
    Apr 20 20:09:01 server1 postfix/smtpd[2272]: lost connection after CONNECT from localhost[127.0.0.1]
    Apr 20 20:09:01 server1 postfix/smtpd[2272]: disconnect from localhost[127.0.0.1]
    Apr 20 20:09:01 server1 pop3d: Connection, ip=[::ffff:127.0.0.1]
    Apr 20 20:09:01 server1 pop3d: Disconnected, ip=[::ffff:127.0.0.1]
    Apr 20 20:09:01 server1 imapd: Connection, ip=[::ffff:127.0.0.1]
    Apr 20 20:09:01 server1 imapd: Disconnected, ip=[::ffff:127.0.0.1], time=0
    Apr 20 20:10:01 server1 postfix/smtpd[2272]: connect from localhost[127.0.0.1]
    Apr 20 20:10:01 server1 postfix/smtpd[2272]: lost connection after CONNECT from localhost[127.0.0.1]
    Apr 20 20:10:01 server1 postfix/smtpd[2272]: disconnect from localhost[127.0.0.1]
    Apr 20 20:10:01 server1 pop3d: Connection, ip=[::ffff:127.0.0.1]
    Apr 20 20:10:01 server1 pop3d: Disconnected, ip=[::ffff:127.0.0.1]
    Apr 20 20:10:01 server1 imapd: Connection, ip=[::ffff:127.0.0.1]
    Apr 20 20:10:01 server1 imapd: Disconnected, ip=[::ffff:127.0.0.1], time=0
    Apr 20 20:10:02 server1 postfix/smtpd[2272]: connect from localhost[127.0.0.1]
    Apr 20 20:10:02 server1 postfix/smtpd[2272]: lost connection after CONNECT from localhost[127.0.0.1]
    Apr 20 20:10:02 server1 postfix/smtpd[2272]: disconnect from localhost[127.0.0.1]
    Apr 20 20:10:02 server1 pop3d: Connection, ip=[::ffff:127.0.0.1]
    Apr 20 20:10:02 server1 pop3d: Disconnected, ip=[::ffff:127.0.0.1]
    Apr 20 20:10:02 server1 imapd: Connection, ip=[::ffff:127.0.0.1]
    Apr 20 20:10:02 server1 imapd: Disconnected, ip=[::ffff:127.0.0.1], time=0
    
    And regarding the receiving mail part:

    Code:
    Apr 20 20:16:49 server1 named[1016]: error (network unreachable) resolving '169.212.85.209.in-addr.arpa/PTR/IN': 2001:7fe::53#53
    Apr 20 20:16:49 server1 named[1016]: error (network unreachable) resolving '169.212.85.209.in-addr.arpa/PTR/IN': 2001:67c:e0::1#53
    Apr 20 20:16:49 server1 named[1016]: error (network unreachable) resolving '169.212.85.209.in-addr.arpa/PTR/IN': 2001:500:87::87#53
    Apr 20 20:16:49 server1 named[1016]: error (network unreachable) resolving '169.212.85.209.in-addr.arpa/PTR/IN': 2001:43f8:110::10#53
    Apr 20 20:16:49 server1 named[1016]: error (network unreachable) resolving '169.212.85.209.in-addr.arpa/PTR/IN': 2001:500:13::73#53
    Apr 20 20:16:49 server1 named[1016]: error (network unreachable) resolving '169.212.85.209.in-addr.arpa/PTR/IN': 2001:dd8:6::101#53
    Apr 20 20:16:49 server1 named[1016]: error (network unreachable) resolving 'z.arin.net/A/IN': 2001:500:31::108#53
    Apr 20 20:16:49 server1 named[1016]: error (network unreachable) resolving '174.212.85.209.in-addr.arpa/PTR/IN': 2001:5a0:10::2#53
    Apr 20 20:16:49 server1 named[1016]: error (network unreachable) resolving '174.212.85.209.in-addr.arpa/PTR/IN': 2001:500:14:6050:ad::1#53
    Apr 20 20:16:49 server1 named[1016]: error (network unreachable) resolving 'in-addr.arpa/DS/IN': 2001:dc3::35#53
    Apr 20 20:16:50 server1 named[1016]: error (network unreachable) resolving '125.74.in-addr.arpa/DS/IN': 2001:500:f0::63#53
    Apr 20 20:16:50 server1 named[1016]: error (network unreachable) resolving '125.74.in-addr.arpa/DS/IN': 2001:500:13::63#53
    Apr 20 20:16:50 server1 named[1016]: error (network unreachable) resolving '74.in-addr.arpa/DNSKEY/IN': 2001:500:31::63#53
    Apr 20 20:16:50 server1 named[1016]: error (network unreachable) resolving '74.in-addr.arpa/DNSKEY/IN': 2001:500:98::63#53
    Apr 20 20:16:50 server1 postfix/smtpd[2493]: connect from mail-we0-f178.google.com[74.125.82.178]
    Apr 20 20:16:50 server1 postfix/smtpd[2272]: connect from mail-wi0-f169.google.com[209.85.212.169]
    Apr 20 20:16:50 server1 postfix/smtpd[2491]: connect from mail-wi0-f174.google.com[209.85.212.174]
    Apr 20 20:16:50 server1 postfix/smtpd[2493]: NOQUEUE: reject: RCPT from mail-we0-f178.google.com[74.125.82.178]: 554 5.7.1 <postmaster@domain.dk>: Relay access denied; from=<mail@gmail.com> to=<postmaster@domain.dk> proto=ESMTP helo=<mail-we0-f178.google.com>
    Apr 20 20:16:50 server1 postfix/smtpd[2493]: disconnect from mail-we0-f178.google.com[74.125.82.178]
    Apr 20 20:16:50 server1 postfix/smtpd[2491]: NOQUEUE: reject: RCPT from mail-wi0-f174.google.com[209.85.212.174]: 554 5.7.1 <postmaster@domain.dk>: Relay access denied; from=<mail@gmail.com> to=<postmaster@domain.dk> proto=ESMTP helo=<mail-wi0-f174.google.com>
    Apr 20 20:16:50 server1 postfix/smtpd[2272]: NOQUEUE: reject: RCPT from mail-wi0-f169.google.com[209.85.212.169]: 554 5.7.1 <postmaster@domain.dk>: Relay access denied; from=<mail@gmail.com> to=<postmaster@domain.dk> proto=ESMTP helo=<mail-wi0-f169.google.com>
    Apr 20 20:16:50 server1 postfix/smtpd[2491]: disconnect from mail-wi0-f174.google.com[209.85.212.174]
    Apr 20 20:16:50 server1 postfix/smtpd[2272]: disconnect from mail-wi0-f169.google.com[209.85.212.169]
    
     
    Last edited: Apr 20, 2013
  13. danhansen@denmark

    danhansen@denmark HowtoForge Supporter

    OK - did tail -f /var/log/mysql/mysql.log

    Code:
    
    root@server1:/home/administrator# tail -f /var/log/mysql/mysql.log
    
                      291 Quit
    130420 20:51:01   294 Connect   ispconfig@localhost on dbispconfig
                      294 Query     SET NAMES utf8
                      294 Query     SET character_set_results = 'utf8', character_set_client = 'utf8', character_set_connection = 'utf8', character_set_database = 'utf8', character_set_server = 'utf8'
                      294 Query     SELECT * FROM server WHERE server_id = 1
                      294 Query     SELECT * FROM server WHERE server_id = 1
                      294 Query     SELECT count(server_id) as number from sys_datalog WHERE datalog_id > 790 AND (server_id = 1 OR server_id = 0)
                      294 Query     SELECT * FROM server WHERE server_id = 1
                      294 Query     SELECT action_id, action_type, action_param FROM sys_remoteaction WHERE server_id = 1  AND  action_id > 0 ORDER BY action_id
                      294 Quit
    130420 20:51:43   296 Connect   ispconfig@localhost on dbispconfig
                      296 Query     SELECT access FROM mail_access WHERE source='postmaster@domain.dk' and type = 'recipient' and active = 'y' and server_id = 1
                      296 Query     SELECT access FROM mail_access WHERE source='domain.dk' and type = 'recipient' and active = 'y' and server_id = 1
                      296 Query     SELECT access FROM mail_access WHERE source='dk' and type = 'recipient' and active = 'y' and server_id = 1
                      296 Query     SELECT access FROM mail_access WHERE source='postmaster@' and type = 'recipient' and active = 'y' and server_id = 1
                      297 Connect   ispconfig@localhost on dbispconfig
                      297 Query     SELECT access FROM mail_access WHERE source='postmaster@domain' and type = 'recipient' and active = 'y' and server_id = 1
                      297 Query     SELECT access FROM mail_access WHERE source='domain.dk' and type = 'recipient' and active = 'y' and server_id = 1
                      297 Query     SELECT access FROM mail_access WHERE source='dk' and type = 'recipient' and active = 'y' and server_id = 1
                      297 Query     SELECT access FROM mail_access WHERE source='domain@' and type = 'recipient' and active = 'y' and server_id = 1
                      298 Connect   ispconfig@localhost on dbispconfig
                      298 Query     SELECT access FROM mail_access WHERE source='domain@domain.dk' and type = 'recipient' and active = 'y' and server_id = 1
                      298 Query     SELECT access FROM mail_access WHERE source=domain.dk' and type = 'recipient' and active = 'y' and server_id = 1
                      298 Query     SELECT access FROM mail_access WHERE source='dk' and type = 'recipient' and active = 'y' and server_id = 1
                      298 Query     SELECT access FROM mail_access WHERE source='postmaster@' and type = 'recipient' and active = 'y' and server_id = 1
    
    ^C
    
    You have new mail in /var/mail/root
    root@server1:/home/administrator# mysql -e "PASTE THE ENTIRE QUERY FROM THE MYSQL LOG FILE HERE;"
    ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
    root@server1:/home/administrator#
    
    
    I'm sorry, to g.. d... stupid. :eek:

    Think we are talking total reinstallation, again...:(
     
  14. danhansen@denmark

    danhansen@denmark HowtoForge Supporter

    tail -f /var/log/mysql/mysql.log

    Hi,

    Replied the wrong place - hope this is better...

    Code:
    
    root@server1:/home/administrator# tail -f /var/log/mysql/mysql.log
    
                      291 Quit
    130420 20:51:01   294 Connect   ispconfig@localhost on dbispconfig
                      294 Query     SET NAMES utf8
                      294 Query     SET character_set_results = 'utf8', character_set_client = 'utf8', character_set_connection = 'utf8', character_set_database = 'utf8', character_set_server = 'utf8'
                      294 Query     SELECT * FROM server WHERE server_id = 1
                      294 Query     SELECT * FROM server WHERE server_id = 1
                      294 Query     SELECT count(server_id) as number from sys_datalog WHERE datalog_id > 790 AND (server_id = 1 OR server_id = 0)
                      294 Query     SELECT * FROM server WHERE server_id = 1
                      294 Query     SELECT action_id, action_type, action_param FROM sys_remoteaction WHERE server_id = 1  AND  action_id > 0 ORDER BY action_id
                      294 Quit
    130420 20:51:43   296 Connect   ispconfig@localhost on dbispconfig
                      296 Query     SELECT access FROM mail_access WHERE source='postmaster@domain.dk' and type = 'recipient' and active = 'y' and server_id = 1
                      296 Query     SELECT access FROM mail_access WHERE source='domain.dk' and type = 'recipient' and active = 'y' and server_id = 1
                      296 Query     SELECT access FROM mail_access WHERE source='dk' and type = 'recipient' and active = 'y' and server_id = 1
                      296 Query     SELECT access FROM mail_access WHERE source='postmaster@' and type = 'recipient' and active = 'y' and server_id = 1
                      297 Connect   ispconfig@localhost on dbispconfig
                      297 Query     SELECT access FROM mail_access WHERE source='postmaster@domain' and type = 'recipient' and active = 'y' and server_id = 1
                      297 Query     SELECT access FROM mail_access WHERE source='domain.dk' and type = 'recipient' and active = 'y' and server_id = 1
                      297 Query     SELECT access FROM mail_access WHERE source='dk' and type = 'recipient' and active = 'y' and server_id = 1
                      297 Query     SELECT access FROM mail_access WHERE source='domain@' and type = 'recipient' and active = 'y' and server_id = 1
                      298 Connect   ispconfig@localhost on dbispconfig
                      298 Query     SELECT access FROM mail_access WHERE source='domain@domain.dk' and type = 'recipient' and active = 'y' and server_id = 1
                      298 Query     SELECT access FROM mail_access WHERE source=domain.dk' and type = 'recipient' and active = 'y' and server_id = 1
                      298 Query     SELECT access FROM mail_access WHERE source='dk' and type = 'recipient' and active = 'y' and server_id = 1
                      298 Query     SELECT access FROM mail_access WHERE source='postmaster@' and type = 'recipient' and active = 'y' and server_id = 1
    
    ^C
    
    You have new mail in /var/mail/root
    root@server1:/home/administrator# mysql -e "PASTE THE ENTIRE QUERY FROM THE MYSQL LOG FILE HERE;"
    ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
    root@server1:/home/administrator#
    
    
    I'm sorry, to g.. d... stupid. :eek:

    Think we are talking total reinstallation, again...:(

    The onlý other place I could find which relate to this was this:
    http://www.howtoforge.com/forums/showthread.php?t=49546
    But I need a guru to confirm it..
     
    Last edited: Apr 20, 2013
  15. markc

    markc New Member

    Presumably you know what the root password to MySQL is as it will ask for it below...

    mysql -u root -p -e "SELECT access FROM mail_access WHERE source='postmaster@domain.dk' and type = 'recipient' and active = 'y' and server_id = 1;" dbispconfig
     
  16. danhansen@denmark

    danhansen@denmark HowtoForge Supporter

    The do-release-upgrade from Ubuntu 10.04 - 12.04 did it!

    Hi,

    The do-release-upgrade from Ubuntu 10.04 - 12.04 did it! I'm sure..
    There was corrections to be made regarding ipv6 which we fixed. Now I can see files as /etc/postfix/main.cf , /etc/postfix/master.cf and others which is totally different compared to the samples of the tutorial "The Perfect Server - Ubuntu 12.04".
    Therefor I will make an reinstallation, again. But with the 12.04 from the beginning. Then lets see if it betters the errors with postfix/Relay access denied..

    The error earlier on in this thread: "warning: dict_nis_init: NIS domain name not set - NIS lookups disabled" was "nuked" by a very sharp player "MarkC". The fix can be found further up this thread. So thanks for that Mark!

    I will enter the result here in this thread - it might help some others who upgraded from ubuntu 10.04 --> 12.04 and ran into the same errors..

    To be continued...
     
    Last edited: Apr 21, 2013
  17. danhansen@denmark

    danhansen@denmark HowtoForge Supporter

    Reinstallation - From Ubuntu 10.04 upgraded to 12.04 to a reinstalled Ubuntu 12.04

    Hello everyone,

    I'm happy to be able to tell you that the ISPconfig 3 on Ubuntu Server 12.04 works perfectly and have been for 24 hours now.. Mail keeps on working just fine..

    So my advice to peole with a Ubuntu 10.04 release upgraded to 12.04, if you are having mailproblems like the ones we have discussed her, to reinstall the server. Please keep in mind that I'm no guru - and therefore please take this advice for exactly what it is - an advice ;)

    Special thanks to Mark C. of this forum!
     

Share This Page