Relay access denied

Discussion in 'Installation/Configuration' started by maxx, Jul 26, 2005.

  1. maxx

    maxx ISPConfig Developer

    Hello.

    I keep having problems with Fedora 4.

    First didnt get any email to my account. Now I have this problem:

    The Postfix program

    <joakim@xxxxx.xx>: host xxxxx.xx [195.197.xxx.xx] said: 554 <joakim@xxxxx.xx>:
    Relay access denied (in reply to RCPT TO command)

    Can you help me? Thanks!
     
  2. jojo

    jojo HowtoForge Supporter

    You have to turn on SMTP-AUTH for your Postfix. Falko has just written a tutorial about how to do this on Fedora 4: http://www.howtoforge.com/perfect_setup_fedora_core_4

    And in your email client, you must activate "Server needs authentication" (or similar) to be able to send emails with your Postfix.

    jojo
     
  3. maxx

    maxx ISPConfig Developer

    Did that, but ill do it again, if I did something wrong. Problem before was that I didnt receive mail and it doesnt come back to sender...

    Lets see again...

    Thanks.

     
  4. jojo

    jojo HowtoForge Supporter

    Can you see anything related to this behaviour in /var/log/maillog?

    jojo
     
  5. maxx

    maxx ISPConfig Developer

    Yes I can. Ill do reinstall. Lets see after that. Thanks.
     
  6. Maximus_DDT

    Maximus_DDT New Member

    HELP!! Relay access denied in UBUNTU 7.04 Server

    HELP!! I install UBUNTU 7.04 as MailServer, the system let me receive mail, but don't let send external mail :eek:(

    i follow the steps from
    The Perfect Setup - Ubuntu 6.06 LTS Server (Dapper Drake) - Page 5

    so i don't know what to do.

    I tried modify main.cf mynetworks including my local ip/24 but don't work.

    I'm using outlook in my clients and when i check for "Server needs authentication" always ask for user and password, and i write it and ask me again and again and don't let me see if the mail has send.

    (sorry my English its not good)
     
  7. falko

    falko Super Moderator

    Are you sure that you use the correct username and password?
    Any errors in your mail log?
     
  8. Maximus_DDT

    Maximus_DDT New Member

    Yeap!! I use the correct user and password. And the problem still the same :confused:
     
  9. Maximus_DDT

    Maximus_DDT New Member

    554 5.7.1 <***@gmail.com>: Relay access denied

    thats the message in outlook
     
  10. falko

    falko Super Moderator

    What's in /etc/postfix/main.cf? Any errors in /var/log/mail.log?

    What's the output of
    Code:
    telnet localhost 25
    and then
    Code:
    ehlo localhost
    ?
     
  11. Maximus_DDT

    Maximus_DDT New Member

    my big trouble

    The content of main. cf
    and the content of telnet
    and there are many ERRORs in /var/log/mail.log :confused:
    like these:
    i don't know that to do
     
  12. falko

    falko Super Moderator

  13. Maximus_DDT

    Maximus_DDT New Member

    ups :(
    when i tried to execute the code this message appear:
    I wrote like this
     
  14. falko

    falko Super Moderator

    Please do it as root.
     
  15. Maximus_DDT

    Maximus_DDT New Member

    I tried again reinstalling all the system :(
    then when I run as root:
    appears:
     
  16. Maximus_DDT

    Maximus_DDT New Member

  17. hahni

    hahni New Member

    The "/etc/postfix/virtusertable"-File contains the following entries:

    Code:
    test@www.070790.de    070790.de_test
    070790.de_test@www.070790.de    070790.de_test
    
    The problem seems to be, that "test@070790.de" will not work, because ISPConfig 2 only add "test@www.070790.de". What can be done?
     
  18. falko

    falko Super Moderator

    Does 070790.de (without a hostname) exist on the Co-Domains tab? If not, please create it.
     

Share This Page