Relay access denied (SASL support is not compiled in)

Discussion in 'Installation/Configuration' started by yurnero, Aug 19, 2010.

  1. yurnero

    yurnero New Member


    I set up postfix with SMTP-AUTH on Fedora and I got "Relay access denied" when using a mail client such as outlook to send out an email. I also installed dovecot and roundcube on the system and I can send and receive an email on the roundcube webmail. It is worked properly. But I got the "Relay access denied" on sending an email from the mail client.

    I tried to find out a problem and I read the thread, and I also followed the chapter 10 in It is pretty helpful. But the problem is still there. I tried to telnet on port 25 but I did not see the 250-STARTTLS and 250-AUTH PLAIN LOGIN yet. I also set smtpd_tls_loglevel = 14 in the and I see "warning: smtpd_sasl_auth_enable is true, but SASL support is not compiled in" and "warning: TLS has been selected, but TLS support is not compiled in" in the maillog. Can you guide me to to recompile postfix to support SASL and TLS?

    Do I need to use the pam as described on

    What I need is an SMTP server that I can send out an email from a mail client with authorised users and I can also access mailbox from the roundcube webmail as it is worked fine now.
  2. falko

    falko Super Moderator ISPConfig Developer

    Did you enable "Server requires authentication" in your email client?

    What's the output of
    telnet localhost 25
    and then
    ehlo localhost

    Any errors in your mail log?

    Which distribution do you use? Which tutorial (URL) did you use?
  3. yurnero

    yurnero New Member

    Hi Falko,
    Thank you for your response. After I re-installed the packages by following steps in "" and "", the error is gone. It needs to specify the include path and library of saslauthd when compiling a postfix. So, the errors(SASL and TLS support is not compiled in) is disappeared now. But I get "SASL authentication failure" in the maillog. Maybe I missed to install some more packages or the postfix config is not correct yet. (not sure)

    Could you please give me a suggestion what I need to do? What I want is "a mail system that can be accessed by web and mail client. I installed mysql + postfix + saslauthd + dovecot + roundcube. I can access the mail system from roundcube web interface but I got a problem when sending an email from a mail client. For example, I have 3 mail users as [email protected], [email protected] and [email protected]. I can login as these users on the roundcube web interface for sending and receiving an email. But I got an error when I sent out an email from mail client(outlook, login as one of these users) to the smtp server. If I want to use this solution, do I need to install more packages? (Or just need to correct some configs) Do you have an installation guide of this mail solution?

    I saw you installed postfix + courier + mysql + squirrelmail in
    "". This is another solution of mail system that you use the courier and squirrelmail instead of dovecot and roundcube, right? I understand that squirrelmail is another webmail as the same as roundcube. What is about courier? Does it work as the same function as dovecot?

    What's about the pam? (as described on Do I need to configure it for user authorisation?

Share This Page