Relay access denied on ispconfig 2

Discussion in 'General' started by gaozone, Dec 2, 2009.

  1. gaozone

    gaozone New Member

    Relay access denied on ispconfig 2 [SOLVED]

    Hi...
    I have installed ispconfig 2 correctly installed, but
    i have a problem when i try to send e-mail using
    a mail client on my PC to any mail account with other domain.

    Examble
    my e-mail is [email protected]

    if sent e-mail to [email protected], works OK

    if sent e-mail to [email protected], i receive this message "Relay access denied"

    I have a ISPCONFIG 2 installed on ubuntu server 9.04

    regards.

    __________________________________________________ ___

    I solv the problem, adding this line at the end of my main.cf

    smtpd_recipient_restrictions = permit, reject_unauth_destination

    now i can send e-mail from my client without restrictions
     
    Last edited: Dec 3, 2009
  2. Mark_NL

    Mark_NL New Member

    You need to enable SMTP authentication when you want to send email (through your mailserver) to an email address that is not hosted on the mailserver itself.
     
  3. gaozone

    gaozone New Member

    Solved !

    Thanks man, but i don solv the problem with your instrution.

    _____________________________________________________

    I solv the problem, adding this line at the end of my main.cf

    smtpd_recipient_restrictions = permit, reject_unauth_destination

    now i can send e-mail from my client without restrictions :)
     
  4. Mark_NL

    Mark_NL New Member

    i hope you didn't created an open relay server, else you'll be sending millions of spam mails per day in no time .. good luck!

    while this is still true, all jokes aside .. use this:

    Code:
    smtpd_recipient_restrictions =
        permit_sasl_authenticated,
        permit_mynetworks,
        reject_unauth_destination,
        reject_invalid_hostname,
        reject_rbl_client virbl.dnsbl.bit.nl,
        reject_rbl_client cbl.abuseat.org,
        reject_rbl_client bl.spamcop.net,
        reject_rbl_client sbl-xbl.spamhaus.org
    these settings + amavisd + clamav + spamassassin blocks effectivly 98-99% of all unwanted email we receive (we've got servers that receive over 500.000 mails per day)

    with these settings, you must use sasl_authentication daemon .. but if you installed ispconfig2 with the how-to, then you mostlikely have it running.
     

Share This Page