Relay access denied for every new domain

Discussion in 'Installation/Configuration' started by dimitar, Apr 27, 2007.

  1. dimitar

    dimitar New Member

    Hi All,

    I have big problems with the mailsystem on one of my servers running Debian sarge + ISPconfig 2.2.11. I get always:

    <user@domain.com>: host mail.domain.com[xx.xx.xx.xx] said: 554
    <user@domain.com>: Relay access denied (in reply to RCPT TO command)

    when adding new domains or users. I have figured out that when adding a new domain it does not go to: /etc/postfix/local-host-names, and when adding a new user it does not go to: /etc/postfix/virtusertable, i always do that manually, but its becoming a problem because the domains are getting more and more...
    postfix works with mbox format (for a reason)

    Please help me to isolate the problem

    thanks in advance
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Any errors in the file:

    /home/admispconfig/ispconfig/ispconfig.log ?
     
  3. dimitar

    dimitar New Member

    No not errors just INFO

    when adding a domain:

    27.04.2007 - 11:06:02 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1029: cp -fr /root/ispconfig/isp/error_en /var/www/web333/web/error
    27.04.2007 - 11:06:02 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1037: cp -fr /root/ispconfig/isp/standard_index.html_en /var/www/web333/web/index.html
    27.04.2007 - 11:06:02 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1069: ln -s /var/www/web333 /var/www/www.dim_test
    27.04.2007 - 11:06:02 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 93: setquota -g web333 102400 102400 0 0 -a &> /dev/null
    27.04.2007 - 11:06:02 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 136: cp -fr /etc/postfix/local-host-names /etc/postfix/local-host-names~
    27.04.2007 - 11:06:04 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 283: cp -fr /etc/postfix/virtusertable /etc/postfix/virtusertable~
    27.04.2007 - 11:06:04 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 288: postmap hash:/etc/postfix/virtusertable
    27.04.2007 - 11:06:04 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1190: cp -fr /etc/apache2/vhosts/Vhosts_ispconfig.conf /etc/apache2/vhosts/Vhosts_ispconfig.conf~
    27.04.2007 - 11:06:04 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1833: httpd -t &> /dev/null
    27.04.2007 - 11:06:04 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1833: httpd -t &> /dev/null
    27.04.2007 - 11:06:04 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1833: httpd -t &> /dev/null
    27.04.2007 - 11:06:05 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1833: httpd -t &> /dev/null
    27.04.2007 - 11:06:05 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1833: httpd -t &> /dev/null
    27.04.2007 - 11:06:06 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 2374: httpd -t &> /dev/null
    27.04.2007 - 11:06:06 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 2376: httpd syntax ok
    27.04.2007 - 11:06:07 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 696: /etc/init.d/apache2 reload &> /dev/null
    27.04.2007 - 11:06:07 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 696: /etc/init.d/postfix stop &> /dev/null
    27.04.2007 - 11:06:07 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 696: /etc/init.d/postfix start &> /dev/null
    27.04.2007 - 11:06:07 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1858: cp -fr /etc/proftpd_ispconfig.conf /etc/proftpd_ispconfig.conf


    when adding user:

    27.04.2007 - 11:09:58 => INFO - USER:
    a123456789:x:11140:10285::/var/www/web285:/bin/false
    27.04.2007 - 11:09:58 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 649: cp -fr /root/ispconfig/isp/user_standard_index.html_en /var/www/web285/user/a123456789/web/index.html
    27.04.2007 - 11:09:58 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 697: create /var/spool/mail/a123456789
    27.04.2007 - 11:09:58 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 698: chown a123456789:mail /var/spool/mail/a123456789 &> /dev/null
    27.04.2007 - 11:09:58 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 699: chmod 600 /var/spool/mail/a123456789
    27.04.2007 - 11:09:58 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 708: setquota -u a123456789 1024 1024 0 0 -a &> /dev/null
    27.04.2007 - 11:09:58 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_procmail.lib.php, Line 57: cp -f /root/ispconfig/isp/conf/forward.master /var/www/web285/.forward
    27.04.2007 - 11:09:58 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 136: cp -fr /etc/postfix/local-host-names /etc/postfix/local-host-names~
    27.04.2007 - 11:10:00 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 283: cp -fr /etc/postfix/virtusertable /etc/postfix/virtusertable~
    27.04.2007 - 11:10:00 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 288: postmap hash:/etc/postfix/virtusertable
    27.04.2007 - 11:10:00 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1190: cp -fr /etc/apache2/vhosts/Vhosts_ispconfig.conf /etc/apache2/vhosts/Vhosts_ispconfig.conf~
    27.04.2007 - 11:10:00 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1833: httpd -t &> /dev/null
    27.04.2007 - 11:10:00 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1833: httpd -t &> /dev/null
    27.04.2007 - 11:10:01 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1833: httpd -t &> /dev/null
    27.04.2007 - 11:10:01 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1833: httpd -t &> /dev/null
    27.04.2007 - 11:10:02 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1833: httpd -t &> /dev/null
    27.04.2007 - 11:10:02 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1858: cp -fr /etc/proftpd_ispconfig.conf /etc/proftpd_ispconfig.conf~
     
  4. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    ls -la /root/ispconfig
    ?
     
  5. dimitar

    dimitar New Member

    ls -la /root/ispconfig
    total 124
    drwxr-xr-x 9 root root 4096 2007-04-30 07:32 .
    drwxr-xr-x 6 root root 4096 2007-04-28 11:43 ..
    -rwxr-xr-x 1 root root 53929 2007-03-27 08:58 cronolog
    -rwxr-xr-x 1 root root 9673 2007-03-27 08:58 cronosplit
    drwxr-xr-x 12 root root 4096 2007-03-27 08:51 httpd
    drwxr-xr-x 12 root root 4096 2007-03-27 08:58 isp
    -rw-r--r-- 1 root root 8 2007-04-30 07:32 .old_path_httpd_root
    drwxr-xr-x 6 root root 4096 2007-03-27 08:48 openssl
    drwxr-xr-x 6 root root 4096 2007-03-27 08:54 php
    drwxr-xr-x 4 root root 4096 2007-03-27 08:58 scripts
    drwxr-xr-x 4 root root 4096 2007-03-27 08:58 standard_cgis
    drwxr-xr-x 2 root root 4096 2007-03-27 08:58 sv
    -rwx------ 1 root root 9504 2007-03-27 08:58 uninstall
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Looks ok. Do you get any error messages when you run
    Code:
    /root/ispconfig/php/php /root/ispconfig/scripts/writeconf.php
    on the shell?
     
  7. dimitar

    dimitar New Member

    No errors just:

    /root/ispconfig/php/php /root/ispconfig/scripts/writeconf.php
    start
    ende
     
  8. dimitar

    dimitar New Member

    Btw should /root/ispconfig/php/php /root/ispconfig/scripts/writeconf.php be setuped as cronjob, because i can not see it in my crontab...
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Is the website or co-domain set to external mailserver? If a domain is set to external mailserver, it is not included in the postfix configuration.
     
  10. dimitar

    dimitar New Member


    where is that set?
     
  11. falko

    falko Super Moderator ISPConfig Developer

    For the web site's main domain that is on the Options tab, and for Co-Domains you have to go the the Co-Domain, select the Co-Domain, and then go to the Options tab.
     
  12. edge

    edge Active Member Moderator

    Not sure if this is of any help, but did you try setting "My outgoing server (SMTP) requires authentication" in your email client to on?
     
    Last edited: May 4, 2007
  13. hahni

    hahni New Member

    I have with one domain (not all the same problem). But my /var/log/mail.info tells me an error. But I don't know, how to fix it:

    Code:
    Apr  3 20:52:17 server postfix/smtpd[2012]: connect from sender.domain.de[xxx.xxx.xxx.xxx]
    Apr  3 20:52:17 server postfix/smtpd[2012]: setting up TLS connection from sender.domain.de[xxx.xxx.xxx.xxx]
    Apr  3 20:52:17 server postfix/smtpd[2012]: Anonymous TLS connection established from sender.domain.de[xxx.xxx.xxx.xxx]: TLSv1 with cipher ADH-AES256-SHA (256/256 bits)
    Apr  3 20:52:17 server postfix/smtpd[2012]: NOQUEUE: reject: RCPT from sender.domain.de[xxx.xxx.xxx.xxx]: 554 5.7.1 <0178@9513117.de>: Relay access denied; from=<xxx@senderdomain.de> to=<0178@9513117.de> proto=ESMTP helo=<sender.domain.de>
    Apr  3 20:52:17 server postfix/smtpd[2012]: disconnect from sender.domain.de[xxx.xxx.xxx.xxx]
    
     
  14. falko

    falko Super Moderator ISPConfig Developer

    Did you enable "Server requires authentication" in your email client? Does it work without TLS?
     
  15. hahni

    hahni New Member

    The reason was a missing co-domain without "www". Thanks a lot for your help, Falko!
     
  16. hahni

    hahni New Member

    But the customer with the root server and ISPConfig 2 wants, that the "www" Host is not automatically set. In other words: he want a blank "host"-field, because he only wants on demand the www set. Is that possible?
     
  17. till

    till Super Moderator Staff Member ISPConfig Developer

  18. hahni

    hahni New Member

    Thanks for your answer, Till.
     

Share This Page