Relay access denied 554 5.7.1

Discussion in 'Installation/Configuration' started by DaveN, Jul 21, 2007.

  1. DaveN

    DaveN New Member

    debian etch - perfect install for ispconfig.

    mail client "server requires auth" ticked

    Dave
     
  2. DaveN

    DaveN New Member

    netstat :


    tcp 0 0 *:mysql *:* LISTEN 3688/mysqld
    tcp 0 0 *:sunrpc *:* LISTEN 2619/portmap
    tcp 0 0 *:81 *:* LISTEN 14545/ispconfig_htt
    tcp 0 0 *:auth *:* LISTEN 3118/inetd
    tcp 0 0 *:ftp *:* LISTEN 15022/proftpd: (acc
    tcp 0 0 deb2.bronco.co.u:domain *:* LISTEN 14682/named
    tcp 0 0 localhost.locald:domain *:* LISTEN 14682/named
    tcp 0 0 *:48853 *:* LISTEN 3242/rpc.statd
    tcp 0 0 *:smtp *:* LISTEN 17319/master
    tcp 0 0 localhost.localdoma:953 *:* LISTEN 14682/named
    tcp6 0 0 *:imaps *:* LISTEN 3085/couriertcpd
    tcp6 0 0 *:pop3s *:* LISTEN 3104/couriertcpd
    tcp6 0 0 *:pop3 *:* LISTEN 3090/couriertcpd
    tcp6 0 0 *:imap2 *:* LISTEN 3068/couriertcpd
    tcp6 0 0 *:www *:* LISTEN 14566/apache2
    tcp6 0 0 *:domain *:* LISTEN 14682/named
    tcp6 0 0 *:ssh *:* LISTEN 3202/sshd
    tcp6 0 0 *:smtp *:* LISTEN 17319/master
    tcp6 0 0 ip6-localhost:953 *:* LISTEN 14682/named
    tcp6 0 0 *:https *:* LISTEN 14566/apache2


    postconf :

    alias_database = hash:/etc/aliases
    alias_maps = hash:/etc/aliases
    append_dot_mydomain = no
    biff = no
    broken_sasl_auth_clients = yes
    config_directory = /etc/postfix
    inet_interfaces = all
    inet_protocols = all
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    mydestination = /etc/postfix/local-host-names
    myhostname = deb2.bronco.co.uk
    mynetworks = 127.0.0.0/8
    myorigin = /etc/mailname
    recipient_delimiter = +
    relayhost =
    smtp_tls_note_starttls_offer = yes
    smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache
    smtp_use_tls = yes
    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_local_domain =
    smtpd_sasl_security_options = noanonymous
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_auth_only = no
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
    smtpd_tls_session_cache_timeout = 3600s
    smtpd_use_tls = yes
    tls_random_source = dev:/dev/urandom
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Which is the exact error message that you get in the /var/log/mail.log file?
     
  4. DaveN

    DaveN New Member

    Jul 22 08:08:36 deb2 postfix/smtpd[32536]: connect from vg-1-11.dialup.access.telecore.net.ru[213.135.64.139]
    Jul 22 08:09:43 deb2 postfix/smtpd[32536]: NOQUEUE: reject: RCPT from vg-1-11.dialup.access.telecore.net.ru[213.135.64.139]: 554 5.7.1 <[email protected]>: Relay access denied; from=<[email protected]> to=<[email protected]> proto=SMTP helo=<195.166.60.85>
    Jul 22 08:10:01 deb2 postfix/smtpd[32536]: disconnect from vg-1-11.dialup.access.telecore.net.ru[213.135.64.139]
    Jul 22 08:13:21 deb2 postfix/anvil[32538]: statistics: max connection rate 1/60s for (smtp:213.135.64.139) at Jul 22 08:08:36
    Jul 22 08:13:21 deb2 postfix/anvil[32538]: statistics: max connection count 1 for (smtp:213.135.64.139) at Jul 22 08:08:36
    Jul 22 08:13:21 deb2 postfix/anvil[32538]: statistics: max cache size 1 at Jul 22 08:08:36
    Jul 22 08:31:58 deb2 courierpop3login: Connection, ip=[::ffff:85.189.43.209]
    Jul 22 08:31:59 deb2 courierpop3login: LOGIN, user=web1_dave, ip=[::ffff:85.189.43.209]
    Jul 22 08:32:01 deb2 courierpop3login: LOGOUT, user=web1_dave, ip=[::ffff:85.189.43.209], top=0, retr=0, rcvd=12, sent=39, time=2
    Jul 22 09:02:04 deb2 courierpop3login: Connection, ip=[::ffff:85.189.43.209]
    Jul 22 09:02:04 deb2 courierpop3login: LOGIN, user=web1_dave, ip=[::ffff:85.189.43.209]
    Jul 22 09:02:05 deb2 courierpop3login: LOGOUT, user=web1_dave, ip=[::ffff:85.189.43.209], top=0, retr=0, rcvd=12, sent=39, time=1
    Jul 22 09:04:26 deb2 freshclam[14712]: Received signal: wake up
    Jul 22 09:04:26 deb2 freshclam[14712]: ClamAV update process started at Sun Jul 22 09:04:26 2007
    Jul 22 09:04:26 deb2 freshclam[14712]: SECURITY WARNING: NO SUPPORT FOR DIGITAL SIGNATURES
    Jul 22 09:04:26 deb2 freshclam[14712]: See the FAQ at http://www.clamav.net/support/faq for an explanation.
    Jul 22 09:04:27 deb2 freshclam[14712]: Your ClamAV installation is OUTDATED!
    Jul 22 09:04:27 deb2 freshclam[14712]: Local version: 0.90.3 Recommended version: 0.91.1
    Jul 22 09:04:27 deb2 freshclam[14712]: DON'T PANIC! Read http://www.clamav.net/support/faq
    Jul 22 09:04:27 deb2 freshclam[14712]: main.inc is up to date (version: 44, sigs: 133163, f-level: 20, builder: sven)
    Jul 22 09:04:27 deb2 freshclam[14712]: daily.inc is up to date (version: 3728, sigs: 6496, f-level: 16, builder: ccordes)
    Jul 22 09:04:27 deb2 freshclam[14712]: --------------------------------------
    Jul 22 09:32:21 deb2 courierpop3login: Connection, ip=[::ffff:85.189.43.209]
    Jul 22 09:32:21 deb2 courierpop3login: LOGIN, user=web1_dave, ip=[::ffff:85.189.43.209]
    Jul 22 09:32:21 deb2 courierpop3login: LOGOUT, user=web1_dave, ip=[::ffff:85.189.43.209], top=0, retr=0, rcvd=12, sent=39, time=0
    Jul 22 10:08:04 deb2 postfix/smtpd[1587]: connect from chello089079126009.chello.pl[89.79.126.9]
    Jul 22 10:08:05 deb2 postfix/smtpd[1587]: NOQUEUE: reject: RCPT from chello089079126009.chello.pl[89.79.126.9]: 554 5.7.1 <[email protected]>: Relay access denied; from=<[email protected]> to=<[email protected]> proto=SMTP helo=<chello089079126009.chello.pl>
    Jul 22 10:08:05 deb2 postfix/smtpd[1587]: disconnect from chello089079126009.chello.pl[89.79.126.9]
    Jul 22 10:11:25 deb2 postfix/anvil[1589]: statistics: max connection rate 1/60s for (smtp:89.79.126.9) at Jul 22 10:08:04
    Jul 22 10:11:25 deb2 postfix/anvil[1589]: statistics: max connection count 1 for (smtp:89.79.126.9) at Jul 22 10:08:04
    Jul 22 10:11:25 deb2 postfix/anvil[1589]: statistics: max cache size 1 at Jul 22 10:08:04
    Jul 22 10:52:07 deb2 courierpop3login: Connection, ip=[::ffff:85.189.43.209]
    Jul 22 10:52:07 deb2 courierpop3login: LOGIN, user=web1_dave, ip=[::ffff:85.189.43.209]
    Jul 22 10:52:09 deb2 courierpop3login: LOGOUT, user=web1_dave, ip=[::ffff:85.189.43.209], top=0, retr=0, rcvd=12, sent=39, time=2
    Jul 22 10:53:22 deb2 courierpop3login: Connection, ip=[::ffff:127.0.0.1]
    Jul 22 10:53:22 deb2 courierpop3login: Disconnected, ip=[::ffff:127.0.0.1]
    Jul 22 10:53:22 deb2 postfix/smtpd[2209]: connect from localhost.localdomain[127.0.0.1]
    Jul 22 10:53:22 deb2 postfix/smtpd[2209]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
    Jul 22 10:53:22 deb2 postfix/smtpd[2209]: disconnect from localhost.localdomain[127.0.0.1]
    Jul 22 11:21:57 deb2 courierpop3login: Connection, ip=[::ffff:85.189.43.209]
    Jul 22 11:21:57 deb2 courierpop3login: LOGIN, user=web1_dave, ip=[::ffff:85.189.43.209]
    Jul 22 11:21:58 deb2 courierpop3login: LOGOUT, user=web1_dave, ip=[::ffff:85.189.43.209], top=0, retr=0, rcvd=12, sent=39, time=1
    Jul 22 11:28:27 deb2 freshclam[14712]: Received signal: wake up
    Jul 22 11:28:27 deb2 freshclam[14712]: ClamAV update process started at Sun Jul 22 11:28:27 2007
    Jul 22 11:28:27 deb2 freshclam[14712]: SECURITY WARNING: NO SUPPORT FOR DIGITAL SIGNATURES
    Jul 22 11:28:27 deb2 freshclam[14712]: See the FAQ at http://www.clamav.net/support/faq for an explanation.
    Jul 22 11:28:27 deb2 freshclam[14712]: Your ClamAV installation is OUTDATED!
    Jul 22 11:28:27 deb2 freshclam[14712]: Local version: 0.90.3 Recommended version: 0.91.1
    Jul 22 11:28:27 deb2 freshclam[14712]: DON'T PANIC! Read http://www.clamav.net/support/faq
    Jul 22 11:28:27 deb2 freshclam[14712]: main.inc is up to date (version: 44, sigs: 133163, f-level: 20, builder: sven)
    Jul 22 11:28:27 deb2 freshclam[14712]: daily.inc is up to date (version: 3728, sigs: 6496, f-level: 16, builder: ccordes)
    Jul 22 11:28:27 deb2 freshclam[14712]: --------------------------------------
    Jul 22 11:52:06 deb2 courierpop3login: Connection, ip=[::ffff:85.189.43.209]
    Jul 22 11:52:06 deb2 courierpop3login: LOGIN, user=web1_dave, ip=[::ffff:85.189.43.209]
    Jul 22 11:52:06 deb2 courierpop3login: LOGOUT, user=web1_dave, ip=[::ffff:85.189.43.209], top=0, retr=0, rcvd=12, sent=39, time=0
    Jul 22 12:22:11 deb2 courierpop3login: Connection, ip=[::ffff:85.189.43.209]
    Jul 22 12:22:11 deb2 courierpop3login: LOGIN, user=web1_dave, ip=[::ffff:85.189.43.209]
    Jul 22 12:22:11 deb2 courierpop3login: LOGOUT, user=web1_dave, ip=[::ffff:85.189.43.209], top=0, retr=0, rcvd=12, sent=39, time=0
    Jul 22 12:52:19 deb2 courierpop3login: Connection, ip=[::ffff:85.189.43.209]
    Jul 22 12:52:20 deb2 courierpop3login: LOGIN, user=web1_dave, ip=[::ffff:85.189.43.209]
    Jul 22 12:52:20 deb2 courierpop3login: LOGOUT, user=web1_dave, ip=[::ffff:85.189.43.209], top=0, retr=0, rcvd=12, sent=39, time=0
     
  5. DaveN

    DaveN New Member

    Hi Till,

    some extra infomation dns handled by ns0.bronco.co.uk and ns1.bronco.co.uk windows boxes,

    ispconfig is on 195.166.60.85 ( deb2.bronco.co.uk )

    we setup 3xb.co.uk as the test, 1 user dave.

    pointed the mx record at the 195.166.60.85, webmail works fine, it i guess it would been local host. it's just the 3xb users
    __________________________________
    Your message did not reach some or all of the intended recipients.

    Subject: 3xb mail
    Sent: 21/07/2007 14:05

    The following recipient(s) cannot be reached:

    '[email protected]' on 21/07/2007 14:05
    554 5.7.1 <[email protected]>: Relay access denied



    DaveN
     
    Last edited: Jul 22, 2007
  6. falko

    falko Super Moderator ISPConfig Developer

    Please run
    Code:
    postconf -e 'virtual_maps = hash:/etc/postfix/virtusertable'
    /etc/init.d/postfix restart
     
  7. DaveN

    DaveN New Member

    falko

    ran : same error

    Dave
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Please run also the following command:

    Code:
    postconf -e 'mydestination = /etc/postfix/local-host-names'
    /etc/init.d/postfix restart
     
  9. DaveN

    DaveN New Member

    Till, Done that ..

    still the same..

    Dave
     
  10. falko

    falko Super Moderator ISPConfig Developer

    Did you enable "Server requires authentication." in your email client?
     
  11. DaveN

    DaveN New Member

    Falko, Yep auth is on ..

    dave
     
  12. DaveN

    DaveN New Member

    is there anyway to check that I set up SMTP-AUTH And TLS correctly..

    Dave
     
  13. digitalv

    digitalv New Member

    I am having the same issue, but I have one account that is working but none of my other domains are working, I always get the "relay access denied" error message... I ran the two commands mentioned on the previous page and now I can't send mail.... I get this error in my mail.log file...

    Code:
    [2941]: fatal: dict_open: unsupported dictionary type: has:  Is the postfix-has package installed?
    [2771]: warning: process /usr/lib/postfix/cleanup pid 2941 exit status 1
    [2771]: warning: /usr/lib/postfix/cleanup: bad command startup -- throttling
    
    I was at least able to send mail before running those 2 commands, now I can't do anything! Gotta love mail servers ;)
     
  14. digitalv

    digitalv New Member

    Never mind my previous post... I somehow got it to work, I don't know what I did honestly, but its working flawlessly!
     
  15. falko

    falko Super Moderator ISPConfig Developer

    Please run
    Code:
    telnet localhost 25
    and then
    Code:
    ehlo localhost
    What's the output?
    Also, what's in /etc/postfix/main.cf?
    Please double-check that you enabled "Server requires authentication." in your email client (not server).
     
  16. DaveN

    DaveN New Member

    hi falko, i had already do that and it looked, fine so what Did was ..

    postconf -e 'smtpd_sasl_local_domain ='
    postconf -e 'smtpd_sasl_auth_enable = yes'
    postconf -e 'smtpd_sasl_security_options = noanonymous'
    postconf -e 'broken_sasl_auth_clients = yes'
    postconf -e 'smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination'
    postconf -e 'inet_interfaces = all'
    echo 'pwcheck_method: saslauthd' >> /etc/postfix/sasl/smtpd.conf
    echo 'mech_list: plain login' >> /etc/postfix/sasl/smtpd.conf

    And it's working now.. which is odd because that's what I had already done. going to try again on a brand new server, Thanks for Your and Tills help

    Dave
     
  17. av1611

    av1611 New Member

    Feedback

    I installed FC6 via your howto and run ISPConfig on the top. I had this same issue or at least I had to do what the other person did to get my smtp to work. Actually, I only did this part:

    postconf -e 'smtpd_sasl_local_domain ='
    postconf -e 'smtpd_sasl_auth_enable = yes'
    postconf -e 'smtpd_sasl_security_options = noanonymous'
    postconf -e 'broken_sasl_auth_clients = yes'
    postconf -e 'smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination'
    postconf -e 'inet_interfaces = all'

    and it fixed it. I don't understand why, cause they were already set correctly??? Anyways, there's some feedback...

    osprey a*t tru thsoldiers <.> com
     

Share This Page