Rejecting SPAM with amavisd.conf

Discussion in 'HOWTO-Related Questions' started by toolz, Mar 23, 2009.

  1. toolz

    toolz New Member

    Hello All,

    Set up Falcos Virtual Users / Postfix / Fedora 10 Setup and I am having an issue with the delivery of SPAM. We want to reject SPAM coming in. We have set the amavisd.conf with:

    $final_spam_destiny = D_DISCARD;

    But we are still getting the SPAM coming into the email accounts. Is this where it's supposed to take place.

    Again we want the email identified as SPAM to never make it to the users account.

    Any ideas?

    Thanks,

    Toolz
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Did you restart amavisd?
    What's in the mail log when a spam message comes in?
     
  3. toolz

    toolz New Member

    Yes, many times and the machine has been restarted several times.

    And here is an output to some spam in the maillog

    Mar 22 04:39:52 localhost amavis[25515]: (25515-15) Passed SPAM, [41.214.118.160] [41.214.118.160] <bullwinkle00@expodesignepe.com> -> <you@mydomain.com>,<me@mydomain.com>, Message-ID: <000d01c9aacb$4c580650$6400a8c0@bullwinkle00>, mail_id: 49ONQl20XrzO, Hits: 4.524, size: 1729, queued_as: 816A725E21A, 13370 ms

    Hopefully this will help.

    Toolz
     
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Not sure what is wrong. Did you disable SELinux?
     
  5. toolz

    toolz New Member

    Hello Falco,

    Just did a double check to make sure and yes it's disabled. Just a not SPAMASSISN is not running at startup. If I recall correctly, it shouldn't be, right?

    Toolz
     
  6. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Yes, it's called by amavisd.
     

Share This Page