register_globals: how does it work !

Discussion in 'Installation/Configuration' started by guillaume14, Aug 1, 2006.

  1. guillaume14

    guillaume14 New Member

    Hi all !

    I need to build an oscommerce site and i need register_globals to be On. So i have checked the "PHP Scripts" and the "PHP Safe Mode" boxes but i still have the "Server Requirement Error: register_globals is disabled in your PHP configuration" when i launch my site.

    In my "root/ispconfig/php/php.ini" the "register_globals" directive is set to "Off". Is this ok ?

    Thanks a lot !

  2. Stanev

    Stanev New Member

    Hi you should put "php_flag register_globals on" in Apache Directives for this site in ISP Config in Basis tab
  3. guillaume14

    guillaume14 New Member

    Hi Stanev and thaks for your help !

    If i put "php_flag register_globals on" in Apache Directives for this site in ISP Config in Basis tab like u said it does not work and the "# php_flag register_globals on # NOT SUPPORTED!" message is displayed.

    Thank you !
  4. Stanev

    Stanev New Member

  5. wr19026

    wr19026 New Member

    Alternatively use the contrib that fixes the register_global requirement for osC.

    The contrib can be found here. I have to admit that I have downloaded the contrib but not installed it yet so don't yell at me if it requires some additional tweaking :)
  6. guillaume14

    guillaume14 New Member

    Thanks Stanev !

    But that's not a solution: that's a workaround because the solution is to make Oscommerce work with register_globals= Off. But i can't to that cause some of my contributions ar register_globals = On.

    Any tip on how register_globals is working with Ispconfig ?

    Thanks a lot !
  7. falko

    falko Super Moderator ISPConfig Developer

    Did you try
    php_admin_value register_globals On
    in the Apache Directives field of that web sites in ISPConfig, as suggested by Stanev?
  8. xTiNcTion

    xTiNcTion New Member

    tested. this solve the problem

    remember to enable HTTPD (in ISPConfig) to the user that create the site.

Share This Page