Regarding Hdd Mount clarification

Discussion in 'ISPConfig 3 Priority Support' started by pawan, Oct 7, 2017.

  1. pawan

    pawan Member HowtoForge Supporter

    when I run the command lsblk, the output is like this:
    Code:
    NAME   MAJ:MIN RM  SIZE RO TYPE MOUNTPOINT
    sda      8:0    1  1.8T  0 disk
    |-sda1   8:1    1  381M  0 part /boot
    |-sda2   8:2    1    1K  0 part
    |-sda5   8:5    1  1.8T  0 part /
    `-sda6   8:6    1   24G  0 part [SWAP]
    sdb      8:16   1  1.8T  0 disk
    `-sdb1   8:17   1  1.8T  0 part /media/sys-bkp
    what I understand is that when I cd in to /media/sys-bkp I am in the second drive sdb1
    Now when I go to say /media/sys-bkp/var/www/cbsindia.in/web and run a ls command, it lists all the files as in

    /var/www/cbsindia.in/web
    some time back I ran a command rsync -avhx / /media/sys-bkp/
    but cbsindia.in/web/ in sdb1 there should be no file, as I copied it today only, also if I delete the file listed in sdb1 it is deleted from sda5 which shows that even after mount it is listing the files from sda5
    I must be doing something horribly wrong here, don't know what.

    output for command blkid the output is like this:
    Code:
    [email protected]:~# blkid
    /dev/sda1: UUID="01ca4016-efd6-46c4-959a-af70ed4c7335" TYPE="ext3" PARTUUID="20886952-01"
    /dev/sda5: UUID="e14b3398-d632-410f-ab61-a5ad4893d7d6" TYPE="ext4" PARTUUID="20886952-05"
    /dev/sda6: UUID="330a1bfc-f5ba-405d-b4b3-59f3f30c7594" TYPE="swap" PARTUUID="20886952-06"
    /dev/sdb1: UUID="f0180beb-37be-4c09-b632-5188b0edcb6f" TYPE="ext4" PARTUUID="a950ecb8-01"
    This happens only for the folder /var/www
    but I compared say etc folder here the contents are different.

    I want to make a exact copy of hdd1 to hdd2 manually or using cron. (not using RAID)
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The path /var/www/cbsindia.in is a symling which points to /var/www/clients/client.....
    When you make an exact copy, then the symlink is copied as it is. So when you copy the symlink /var/www/cbsindia.in to /media/sys-bkp/, then this symlink must point still to the original location in /var/www. So you did nothing wrong with creating this copy, if you want to check the files of the website that you copied, then check them in the path /media/sys-bkp/var/www/clients/client.....
     

Share This Page