redis socket permissions

Discussion in 'ISPConfig 3 Priority Support' started by Brett Wilton, Jun 17, 2018.

  1. Brett Wilton

    Brett Wilton Member

    I've moved redis over from tcp to creating a socket /var/run/redis/redis.sock however I have issues with nginx and php-fpm talking to the socket.
    Config allows for a unixsocketperm settings which by default suggests 700.
    Directory and socket user is redis and group is redis.
    Just after the best suggestion for allowing the various ispconfig web and clients to access the socket ?
    I have it working with 777, I have tried 750 with group nginx but no luck.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    I don't use Redis, so I can just post some general thoughts here. Have you tried to add the nginx user and/or the web user of that website to the redis group and give the socket 750 or 770 permissions?
  3. Brett Wilton

    Brett Wilton Member

    Will give a few more tests a try, was just trying gauge if there was a specific user or group that socket would need to belong to allowing connection for ispconfig setup web clients.
  4. Brett Wilton

    Brett Wilton Member

    Tried a number of options in giving users redis group permissions but no luck, same with adding redis to apache and nginx users.
    The issue relates to the php5-fpm access to the /var/run/redis/redis.sock.
    Just playing around some more I can set it to 770 with the group sshusers since all ispconfig web clients are members of that group.
    Not sure if that could get locked down further

Share This Page