Redirect not working

Discussion in 'Installation/Configuration' started by jjonsson, Sep 2, 2013.

  1. jjonsson

    jjonsson New Member


    I have setup new ISPconfig3 server on Debian v7.5 x64 and NGINX following this guide:

    Server is running fine and I have created some sites and installed Wordpress on them, so they're ready for our webdesigner to work on.

    I have a problem with 1 site. Existing website is running on another server and it answers on http://www.domain.tld
    On my new ISPconfig server I have created same site as:

    Domain: domain.tld
    Auto Subdomain: None

    Now I just want to edit my hosts file and add

    X.X.X.X domain.tld

    where X.X.X.X is IP-address of my new ISPconfig server.

    That way www.domain.tld would still be available on old server, while webdesigner can work on new ISPconfig server site on domain.tld

    But it's not working. If I in my browser enters http://domain.tld new ISPconfig server for some reasons redirect to http://www.domain.tld.
    I can see that it's the ISPconfig 3 server doing the redirect by doing a scan with Xenu's link sleuth.
    Public DNS has no record/IP-address for domain.tld.

    I have played around with the "redirect tab" on the site in ISPconfig. I have tried the following combinations with no luck:

    Redirect type: Redirect / Permanent
    Redirect path: (I don't know what to write here!)
    SEO Redirect: * => domain.tld / www.domain.tld => domain.tld / *.doman.tld => domain.tld

    What can I do to make this setup work ? Does it have something to do with NGINX ?
    Why are my settings in "redirect tab" ignored ?

    Any help would be appreciated....
  2. jjonsson

    jjonsson New Member

    Shouldn't I be able to have both domain.tld or www.domain.tld pointing at 2 different websites ?
    DNS is setup correctly.....

    It's like ISPconfig3 ignores that I have chosen "Auto subdomain: None"....

    Any help would be appreciated....

Share This Page