Redirect Loop

Discussion in 'Installation/Configuration' started by geekrohit, Jun 25, 2010.

  1. geekrohit

    geekrohit New Member

    I have been having the redirect problem, after creating a subdomain.

    I set the redirect type to No Redirect, to No Flag but nothing helps.
    Its kind of random, cause sometimes the site works.

    Now i have removed the subdomain and created the subdomain as another site.

    Still the problem prevails, and is random in nature.

    I am using ISPConfig 3.0.2.1.

    Thank you.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Then you must have e.g. a .htccaess file in that site or html or php file with a gĀ“header redirect as this problem does not come from ispconfif if you selected no redirect.
     
  3. geekrohit

    geekrohit New Member

    Its a wordpress installation. A default one. That shouldn't give problems?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Such a loop can be caused by wordpress settings itself (e.g. if the domain that is used in the wordpress settings does not match the exact domain / subdomain of the website), a plugin in wordpress or things like wordpress caching plugins. To ensure that it is really not a ispconfig problem, post the vhost file of the affected website.
     
  5. geekrohit

    geekrohit New Member

    Here is the vhost

    <Directory /var/www/cms.iosisnetworks.net>
    AllowOverride None
    Order Deny,Allow
    Deny from all
    </Directory>

    <VirtualHost *:80>
    DocumentRoot /var/www/cms.iosisnetworks.net/web

    ServerName cms.iosisnetworks.net
    ServerAdmin [email protected]

    ErrorLog /var/log/ispconfig/httpd/cms.iosisnetworks.net/error.log

    ErrorDocument 400 /error/400.html
    ErrorDocument 401 /error/401.html
    ErrorDocument 403 /error/403.html
    ErrorDocument 404 /error/404.html
    ErrorDocument 405 /error/405.html
    ErrorDocument 500 /error/500.html
    ErrorDocument 503 /error/503.html

    <Directory /var/www/cms.iosisnetworks.net/web>
    Options FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all

    # ssi enabled
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
    Options +Includes
    </Directory>
    <Directory /var/www/clients/client1/web14/web>
    Options FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all

    # ssi enabled
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
    Options +Includes
    </Directory>

    # suexec enabled
    SuexecUserGroup web14 client1
    # php as fast-cgi enabled
    <IfModule mod_fcgid.c>
    # SocketPath /tmp/fcgid_sock/
    IdleTimeout 3600
    login as: root
    [email protected]'s password:
    Linux iosisnetworks.net 2.6.18-164.15.1.el5.028stab068.9 #1 SMP Tue Mar 30 18:07 :38 MSD 2010 i686 GNU/Linux
    Ubuntu 10.04 LTS

    Welcome to Ubuntu!
    * Documentation: https://help.ubuntu.com/
    Last login: Thu Jun 24 19:13:14 2010 from 115.252.16.81
    root@iosisnetworks:~# vim /etc/apache2/sites-available/cms.iosisnetworks.net.vhost
    # SocketPath /tmp/fcgid_sock/
    IdleTimeout 3600
    ProcessLifeTime 7200
    # MaxProcessCount 1000
    DefaultMinClassProcessCount 3
    DefaultMaxClassProcessCount 100
    IPCConnectTimeout 8
    IPCCommTimeout 360
    BusyTimeout 300
    </IfModule>
    <Directory /var/www/cms.iosisnetworks.net/web>
    AddHandler fcgid-script .php .php3 .php4 .php5
    FCGIWrapper /var/www/php-fcgi-scripts/web14/.php-fcgi-starter .php
    Options +ExecCGI
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>
    <Directory /var/www/clients/client1/web14/web>
    AddHandler fcgid-script .php .php3 .php4 .php5
    FCGIWrapper /var/www/php-fcgi-scripts/web14/.php-fcgi-starter .php
    Options +ExecCGI
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>

    # add support for apache mpm_itk
    <IfModule mpm_itk_module>
    AssignUserId web14 client1
    </IfModule>


    </VirtualHost>
     
  6. geekrohit

    geekrohit New Member

    The .htaccess in webroot is blank by the way, i just checked it.
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    This vhost does not contain any redirect. So you should check the wordpress settings if there is a wrong hostname somewhere.
     
  8. geekrohit

    geekrohit New Member

    Thank you very much Till for the help. For the time being, the site is working again. I will reinstall it again, from scratch.
     

Share This Page