Redirect from http to https

Discussion in 'Installation/Configuration' started by donix, Oct 11, 2010.

  1. donix

    donix New Member

    Hello, I got a debian ISPConfig 3 server with atmailopen webmail installed. I made an alias in apache2 for the webmail. That means the webmail is accessible from https://hostname.tld:8080/webmail.

    When you try to access on http://hostname.tld:8080/webmail it returns a 400 Bad Request:
    Bad Request
    Your browser sent a request that this server could not understand.
    Reason: You're speaking plain HTTP to an SSL-enabled server port.
    Instead use the HTTPS scheme to access this URL, please.
    Is it possible to configure apache to automatically redirect to the https?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Yous hosuld not access webmail trough port 8080 as this might cause problems as you run webmail in the same security context as ispconfig then. use e.g. the ip address or the hostname of your server on port 90 or 443.
  3. donix

    donix New Member

    hmm. okay. Can you outline how to config apache if I want my webmail to be accessible from eg https://hostname.tld:90/webmail

    The important thing is, that I want to serve the webmail on https.
  4. falko

    falko Super Moderator ISPConfig Developer

Share This Page