redirect an application (egroupware) from http to https

Discussion in 'Installation/Configuration' started by blackflag, Feb 20, 2006.

  1. blackflag

    blackflag New Member

    Hello all,
    I have egroupware installed. It is accessible via http and https.
    I want egroupware only accessible via https.
    I tried in apache derictives:

    Redirect /egroupware https://domain.tld/egroupware

    but when I access the url ispconfig says in derictives that it is not supported.

    So, what is the correct way to make an app only accessible via https?
    Or the correct way in ispconfig to do a redirect?

    tia
    stefan
     
  2. falko

    falko Super Moderator

    Is mod_rewrite enabled in your Apache?
     
  3. blackflag

    blackflag New Member

    yes, mod_rewrite is enabled in my apache2 configuration
     
  4. falko

    falko Super Moderator

  5. blackflag

    blackflag New Member

    Okay I tried this and it dont work.
    I get then a message that the limit of redirect is reached for that URL.
    ANd there is no discription about this limit in the link you gave.

    Whats now?

    can someone help

    tia

    stefan
     
  6. blackflag

    blackflag New Member

    should mod_rewrite enabled in ispconfig? Or in my apache2?
    When in ispconfig where can I do this?

    tia
    stefan
     
  7. till

    till Super Moderator

    mod_rewrite must be loaded in your apache configuration and if you want to put rewrite rules in your apache directiveds window you must enable it wit putting this line

    RewriteEngine on

    in the apache directives window too as falko posted above.
     
  8. blackflag

    blackflag New Member

    Last edited: Feb 21, 2006
  9. falko

    falko Super Moderator

    It should be
    Code:
    RewriteEngine on
    Redirect /egroupware [url]https://www.nopanicsystems.net/egroupware[/url]
    This happens because when you go to https://www.nopanicsystems.net/egroupware it is redirected to https://www.nopanicsystems.net/egroupware which is then redirected to https://www.nopanicsystems.net/egroupware and so on - you're in a loop. you must change your redirect rule.
     
  10. blackflag

    blackflag New Member

  11. falko

    falko Super Moderator

    Read the second part of my last post...
     
  12. blackflag

    blackflag New Member

    Code:
    you're in a loop. you must change your redirect rule
    okay, but what should I change. I set it how you meant it :

    Code:
    RewriteEngine on  
    Redirect /egroupware https://www.nopanicsystems.net/egroupware  
    thats what you meant, and thats what I set in ispconfig

    sorry, I dont know what should I change?!
     
  13. falko

    falko Super Moderator

    I just meant that the RewriteEngine line must be at the beginning, before any rewrite rule.

    For the correct Redirect rule, check out this page: http://httpd.apache.org/docs/1.3/misc/rewriteguide.html
     
  14. blackflag

    blackflag New Member

    seems to be solved

    in apache deritives:

    Code:
    RewriteEngine on
    RewriteCond %{SERVER_PORT} !443
    RewriteRule (.*/egroupware) https://www.nopanicsystems.net/egroupware [R]   
    In the moment it seems that all is running!

    okay, thanks for help!!!

    stefan
     

Share This Page